Virtualmin behind NAT, 3 domains, 1st domain web page always shown

I gave up trying to solve this on my own, asking for help :slight_smile:

I have 3 domains, lets name them,,
Public IP: 89.x.x.x
Local IP:
NAT enabled to forward all to

Installation is on a Ubuntu 18. is for webmin. and domains are setup as virtual servers in Virtualmin.

My problem is, no matter what I do, domain’s webpage loads also for domain.

Can this be solved and how?

Thanks in advance!

In Virtualmin -> Virtual Server Summary, is the IP address for each domain?

Is now. That solved the problem. Thank you!

But I had to set this under Virtualmin, Addresses and Networking, Change IP address.

When I tried doing this under Virtualmin, Server Configuration, Change IP Address, it failed for 2nd and further domains as I got an error that the IP is already in use.

Now all I got to figure out is how to get Webmin working with a self signed or LetsEncrypt SLL and it’s a win :slight_smile:
The SSL part of Webmin (not Virtualmin, SSLs work for each domain) is not working and can’t get it to work, with the self signed certificate I get NET::ERR_CERT_COMMON_NAME_INVALID with the browsers, LetsEncrypt returns me an error:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Using the webroot path /home/example1/public_html for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from [89.x.x.x]: “\n\n404 Not Found\n\n

Not Found