Virtualmin Backups via SSH on different port

I’m trying to set up Virtual Server backups from one Virtulamin Pro server to another via the Virtualmin->Backup and Restore->Backup Virtual Sites. For security I’ve changed SSH port from 22 to 99.

The backups do not work and complain that they can’t use port 22.

I’ve set up a .ssh/config file for root to force ssh to use port 99. I have set up keys on the servers so one can ssh into the other without using passwords, and due to the .ssh/config file I don’t need to specify the port.

Is there a way for me to tell Virtualmin to use port 99 for ssh (for the backups), or even get it to use my settings in /root/.ssh/config.



Hey Jef,

You should be able to add the port number to the end of the hostname. For example, something along these lines:

Thanks andreychek

That’s solved it and it’s now working.

I tried -p 99 (usual ssh syntax) but didn’t think to try :99.

Thanks for your help.