Virtualmin Backup - mysqldump failing

In the past week I have noticed that the mysqldump part of the virtualmin scheduled backup has started failing.

The error given is:

mysqldump: Got error: 1045: Access denied for user ‘username’@‘localhost’ (using password: YES) when trying to connect

This happens on all virtualserver backups on my server.

What is baffling is that I can connect remotely, from the server via command line and by managing the database within webmin/virtualmin. I can also run mysqldump manually from the command line without any problems.

I have tried resetting the passwords just in case password file has become corrupted - but this has no effect.

Any ideas?


Same problem here, since update

An update to webmin-virtual-server from 4.12.gpl to 4.13.gpl is available.

I get

Backup failed! See the progress output above for the reason why. Total backup time was 00 minutes, 08 seconds.

Virtual servers that failed :
Sent by Virtualmin at: https://**********.***:10000

Creating backup for virtual server ..
    Copying virtual server configuration ..
    .. done

    Backing up Cron jobs ..
    .. none defined.

    Saving mail aliases ..
    .. done

    Saving mail and FTP users ..
    .. done

    Backing up mail and FTP user Cron jobs ..
    .. none to backup

    Copying Apache virtual host configuration ..
    .. done

    Copying Apache log files ..
    .. done

    Copying Webalizer configuration files ..
    .. done

    Copying Logrotate configuration ..
    .. done

    Dumping MySQL database skafan ..
    .. dump failed! mysqldump: Got error: 1045: Access denied for user 'skafan'@'localhost' (using password: YES) when trying to connect

May this be a bug in virtualmin 4.13 gpl?
I didn’t chance any password (not to MySQL or the user or datebase)!
Only chance I know is virtualmin 4.13… or hacker… :frowning:


i have the same problem, i dont changed anything on servers, 3 servers have problemes backup database with mysqldump .

last backup succes :
08/Jan/2015 17:20
first probleme :
08/Jan/2015 17:30

i just run a upgrade betwen this time :

08/Jan/2015 17:23 : apt-get -y install webmin-virtual-server

and post-install script

on 3 of my servers …
2 servers on debian 6 and one on debian 7

if you want more information, no problemes, but i think the upgrade may cause the problem

if someone can help ^^

thanks you !

read this :

The simpler fix is to edit /etc/webmin/mysql/config and add the line login=root

it works…

for me too, Thank you dabol!

Thanks dabol. Works like a dream.


Hi, I have the same issue here since I updated virtualmin + webmin packages to the latest version. Running Bedian 7 and all is up to date. Error is only regarding mysql dump.

Same here, happened Jan 7 with an update.

The solution posted by dabol works:

read this :

The simpler fix is to edit /etc/webmin/mysql/config and add the line login=root

it works…

Few minutes ago, an update to virtualmin-virtual-server has been published. I installed it and removed the line from config file and my backups seem to work as they should.
Thanks to all the team !

I noticed the update come through as well. I did the update but now apache will not start.
error is as follows.

Failed to start service :

Starting web server: apache2Syntax error on line 38 of /etc/apache2/sites-enabled/
Invalid command ‘php_admin_value’, perhaps misspelled or defined by a module not included in the server configuration
Action ‘start’ failed.
The Apache error log may have more information.

Any ideas as all sites are now down.

I too have been getting this error since the last update, and the only way to get Apache to start is to comment out the offending lines in the conf files for each site - but I think that’s a work-around rather than a fix.

See below for a fix.

I have no idea why apache decided to take the weekend off.

That worked, thanks very much! A little worrying that it broke in the first place though :confused: