VirtualMin as LAN Webserver, unable to see sites..

Hi, I bought an old Compaq server for use as an inhouse webserver in the company I work for so I can run php/sql programs, and thought VirtualMin would be the ideal way to set this up but I’m not having much luck. I’m currently in my flat trying to get everything running before moving the machine in to the racks.

I installed Centos 5.2 fresh with no GUI, just server stuff.
Have run yum update to bring everything up to date
ran and installation went smoothly

I have two ethernet ports on the compaq…
eth0 is hooked up to my router, is accepting IP via DHCP (
eth1 will be used when it’s mounted, and has a static IP
I set the hostname to cdscf07.{domain}.com
I didn’t set anything up in the DNS server fields ** This could be the problem? Should I have entered my router details here? ‘setup’ in CentOS doesn’t let you change this bit, where do I need to look if this is the case? **

hosts file looks like this: localhost.localdomain localhost; cdscf07.{domain}.com cdscf07:
::1 localhost6.localdomain6 localhost6

on my laptop, connected to the router also, if I go to I get the https redirect, and VirtualMin loads up fine.
If I go to , I get a 403 forbidden page. Is this right? I was expecting an Apache page or similar?

I’m happy to make my sites be , for example:
site2.cdscf07.{domain}.com etc

I’ve set these up as virtual sites, everything seems fine but then cannot see these across the LAN. (I followed the FAQ on my original installation, and this didnt work either. I’ve set hosts on my macbook to: cdscf07.{domain}.com test.cdscf07.{domain}.com

and not getting any joy.

As stated earlier, I’m pretty sure it’s the DNS side of things but that’s not something I’ve ever really needed to worry about in hosting online so not something I’ve really messed with before.

Any suggestions? More than happy to copy out any other information that would be useful. Thanks a lot.<br><br>Post edited by: JayX, at: 2009/02/16 04:33

its been a while but under virtualmin tab - system settings - Module Config then look in the right pane as it is.
You need to check if your settings are correct, since you’re behind a router.

  • Network interface for virtual addresses
  • Default virtual server IP address
  • Default IP address for DNS records

you also wouldn’t need the :80 behind the lan ip
have you created a test domain already and was it created successfully under /home ?
If so does the dns domain look fine? virtualmin tab - services - dns domain

Thanks so much, I went into the menu option like you suggested and changed the DNS information to auto find, added to BIND and everything is now working. I can finally stop tearing my hair out!!