Virtualmin/Apache module

Have installed Virtualmin gpl, but when I run the Virtualmin server and check config its states that Apache module "mod_actions" is missing and VirtualMin is not ready to be setup.

I have looked for this module in webmin modules,CPAN,software packages and perl modules but cant find any file relating to it.

Also looked in apt-get and aptitude.

Running Debian etch.

Any ideas?

you can always have a look at your httpd.conf to see if it is there and loading: LoadModule actions_module modules/

webmin-servers-apache webserver-global configuration-edit config files

and under -module config-system configuration- you’'ll see the path to Apache server root directory

Thankyou ronald, all sorted.

Just had to enable actions in apache modules.

Hi all,

I believe I’m having the same problem here. I uncommented the “LoadModule actions_module modules/” line under Webmin>Servers>Apache Webserver>Global configuration>Edit Config Files, but that didn’t fix the issue. I think you’ve mentioned a couple file locations, but I can’t find them on my machine. I’m using Solaris’ Coolstack if that’s any help. The paths are similar, but displaced into the Coolstack folder.


Oop! Nevermind! I fixed it myself! I just needed to double check that everything was properly saved and refresh the configurations stuff. I still have a couple errors, but it says Apache is all set now.

Thanks again!