Virtualmin apache is ignoring the https config completely

OS type and version REQUIRED
Webmin version REQUIRED
Virtualmin version REQUIRED
Related packages SUGGESTED

I have a domain properly setup with my server and also the dns zones and all that are working flawlessly. If I connect normally with http://example.tld it works without any problems how ever when I tried to connect to https://example.tld/dav I realized it won’t load no matter how long I waited. I then opened the page manually and saw that this is because if I enter https it for some reason doesn’t load the contents off example.tld but instead the default server, which in this case is I have no idea why it does this. The cert is from lets encrypt, I tried it with wildcard and without it, both requests where successful. I tried rebooting my VPS with no change, I even temporarily suspended the default server, result was the page not loading with https at all, giving ssl error record to long. At this point I have no idea what to do anymore.

edit: why was my post flagged as spam? I mean example.tld and example2.tld are obviously not my server names. To clear up confusion, it is just a placeholder, my real domain names are different.

have a guess why

1 Like

@stefan1959 I do not have an idea - used to seen those but not any more :slight_smile:

Well that is great question for virtualmin staff ( but I guess its due to keywords sey ,se etx… just replace * with x)… anyway lets focus on OP issue, shall we? I think he uses ipv6 as domain ends xx*.tk which means those are excluded from letsencrypt… now I have no idea if that is true or false but I believe those are not included due to scams etc…

@fhprod if you have an ip who flagged you just send it to virtualmin staff or mentioned them with ‘@ staff’ together without space between @ and staff words and they will look at it and they will solve it for you. I am sorry about it.

You need to make sure that Apache SSL Website feature is enabled for the given virtual server. If so, also check that IP specified on DNS and web-server <VirtualHost> records match.

BTW, you can use in your docs/posts/etc.

See - Wikipedia for more info.


I think this was a sincere post, but damn, you gotta know “sexy, sex, porn” is gonna get flagged…



I needed a good laugh this morning. Thanks.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.