virtualmin and wheezy


i tried to install virtualmin GPL on a debian wheezy and it seems there is a dependency issue on packages about scponly. Does anyone has a solution to this ? I know wheezy is here since a few days so that will be fixed, just wanted to play with it on the meantime :slight_smile:



Yeah there’s a few more changes we’re working on before Debian 7 is formally supported. Once of those is that scponly isn’t offered as a package anymore… we’ll need to remove that from the dependency list.



any ETA when virtualmin / webmin for wheezy will be available?


i was about to ask just for basic scheduling of our upgrade if this is in the pipe for something like a week, a month or much more. If you have any frame that would help us to schedule ourself :slight_smile:


I unfortunately don’t have a specific timeframe, but it should be soon!


would you know if its at all possible to install virtualmin on wheezy via the virtualmin software repositories rather than the install script?


i’ve tried manually adding the repo, but getting:

Conflicting distribution: virtualmin-wheezy Release (expected virtualmin-wheezy but got virtualmin-squeeze)

so im assuming that isnt working either yet?

thanks , good luck with the debian wizardry :slight_smile:


no depedancy issues will be the same.


yes! you are very correct. seems the repository was updated yesterday to show debian 7 in the Releases file… but when installing virtualmin-base:

“The following packages have unmet dependencies:
virtualmin-base : Depends: scponly but it is not installable”

suppose we’ll just have to wait until webmin/vmin devs are done :frowning:

Sorry, it’s almost ready… we’ll post an announcement once it is :slight_smile:

Alternatively, if you just really really want it to work now (knowing that it’s not completed or tested), you could always grab the scponly package from Debian 6, which installs cleanly on Debian 7.


Hey, when you do post the Debian 7 announcement, will there be an updated “how to” or is this post:

the correct steps to use??


I’m kinda jumping into this thread, but I’ve noticed a slight anomoly when doing an aptitude update on squeeze:

aptitude update

Hit squeeze Release.gpg
Ign squeeze/main Translation-en
Ign squeeze/main Translation-en_GB
Hit squeeze-updates Release.gpg
Ign squeeze-updates/main Translation-en
Ign squeeze-updates/main Translation-en_GB
Hit squeeze Release
Hit squeeze-updates Release
Hit squeeze/main Sources
Hit squeeze/main amd64 Packages
Hit squeeze-updates/main Sources/DiffIndex
Hit squeeze-updates/main amd64 Packages/DiffIndex
Hit squeeze-updates/main amd64 Packages
Hit squeeze/updates Release.gpg
Ign squeeze/updates/main Translation-en
Ign squeeze/updates/main Translation-en_GB
Hit squeeze/updates Release
Hit squeeze/updates/main Sources
Hit virtualmin-squeeze Release.gpg
Hit squeeze/updates/main amd64 Packages
Ign virtualmin-squeeze/main Translation-en
Ign virtualmin-squeeze/main Translation-en_GB
Hit virtualmin-universal Release.gpg
Ign virtualmin-universal/main Translation-en
Ign virtualmin-universal/main Translation-en_GB
Hit virtualmin-squeeze Release
Hit virtualmin-universal Release
Hit virtualmin-squeeze/main amd64 Packages
Hit virtualmin-universal/main amd64 Packages
W: Conflicting distribution: virtualmin-squeeze Release (expected virtualmin-squeeze but got virtualmin-wheezy)

… Just in case anyone needed to know…

Hi The repository should be good now.
Be sure to update before upgrade.
Preference for apt-get rather than aptitude for dist-upgrades

Im ready to update my Virtualmin Pro from Debian 6.0 squeeze to Debian 7.0 wheezy.

I want an auto update script or update from the main menu of virtualmin pro.



this still seems to be happening…have just run apt-get update on an older squeeze box:

Hit virtualmin-squeeze Release.gpg
Ign virtualmin-squeeze/main Translation-en
Ign virtualmin-squeeze/main Translation-en_ZW
Hit virtualmin-universal Release.gpg
Ign virtualmin-universal/main Translation-en
Ign virtualmin-universal/main Translation-en_ZW
Hit virtualmin-squeeze Release
Hit virtualmin-universal Release
Hit virtualmin-squeeze/main amd64 Packages
Hit virtualmin-universal/main amd64 Packages
W: Conflicting distribution: virtualmin-squeeze Release (expected virtualmin-squeeze but got virtualmin-wheezy)

the contents of


Architectures: i386 amd64 source
Codename: virtualmin-wheezy
Components: main
Date: Tue, 21 May 2013 01:42:58 UTC
Description: Virtualmin package repository for Debian 7.0
Label: Virtualmin for Debian Wheezy
Origin: Virtualmin, Inc.
Suite: stable
f2525660b3d1fe8f325ee6ee10506d52 2986 main/binary-amd64/Packages
42a0a2993a0b87757f488574b1e7a9e1 1563 main/binary-amd64/Packages.bz2
539b6ad4f1c2d2e9ae80c5b99aed1fb3 1465 main/binary-amd64/Packages.gz
d9d84c1c5d3f64c2e5475d3a1a8f378c 4664 main/binary-i386/Packages
122f824679ca288960b9c6774709bb36 1933 main/binary-i386/Packages.bz2
0c4c85579e8769d3b3646f44a1beab27 1794 main/binary-i386/Packages.gz
623b9aabcf74d6ac55ffaa5eecebbea4985da734 2986 main/binary-amd64/Packages
242909c6cea5d30812fba728281448f60f4e96c9 1563 main/binary-amd64/Packages.bz2
88630f0322f28f3bf23be1ced0e7a60cca2b422d 1465 main/binary-amd64/Packages.gz
5e6a938122c85902ca0bff22d23a4464ef5d243c 4664 main/binary-i386/Packages
4492d5b43f074670872de960a2626ee51a159ef1 1933 main/binary-i386/Packages.bz2
abc166b0ed08c3322a5ff930f55e74d0af09ab8f 1794 main/binary-i386/Packages.gz
0e09c2bb5199bd3cd0b26fc1ed783bc8ef3eedbab90be9767c8b9db820ed0dc0 2986 main/binary-amd64/Packages
d884f95969d32c7c6bda51b32a84af7e7dd72b1a81497e0e7d9e81ceb3620668 1563 main/binary-amd64/Packages.bz2
64c1cd396dc411ce83367e946d5ce6591ac0a1da6c9fc1de81083b5bb1720230 1465 main/binary-amd64/Packages.gz
f32dd988be4ee7190596a95307222ddddec04b180e7db9e400e3d83cd30138fa 4664 main/binary-i386/Packages
b8ef4e63bcfa1dba56297a4651365ed606c6bb6da5685bf6851aca4e147bd785 1933 main/binary-i386/Packages.bz2
a13896b31d246252fac5a6634ecac4f5ac6c6dcb0b8becf769abd5865b624c84 1794 main/binary-i386/Packages.gz

Yeah that Releases file seems remarkably incorrect… I’ve asked Joe to look into it.


Hi Guys,

just to let you know… there is still a “scponly” dependency being looked for in debian wheezy when using the new

i’ve downloaded the install script a few minutes ago. to get the install to work properly on debian wheezy, i had to remove scponly from the dep list inside

specifically from this part of


debdeps=“postfix postfix-pcre webmin usermin ruby libapache2-mod-ruby libxml-simple-perl libcrypt-ssleay-perl unzip zip libfcgi-dev bind9 spamassassin spamc procmail libnet-ssleay-perl libpg-perl libdbd-pg-perl libdbd-mysql-perl quota iptables openssl python mailman subversion ruby irb rdoc ri mysql-server mysql-client mysql-common postgresql postgresql-client awstats webalizer dovecot-common dovecot-imapd dovecot-pop3d proftpd libcrypt-ssleay-perl awstats clamav-base clamav-daemon clamav clamav-freshclam clamav-docs clamav-testfiles libapache2-mod-fcgid apache2-suexec-custom scponly apache2 apache2-doc libapache2-svn libsasl2-2 libsasl2-modules sasl2-bin php-pear php5 php5-cgi libgd2-xpm libapache2-mod-php5 php5-mysql”

ok, and has now just failed with:

The following packages have unmet dependencies:
virtualmin-base : Depends: scponly but it is not installable
WARN - apt-get seems to have failed. Are you sure your OS and version is supported?

oddly enough… im running a second install on a rackspace VPS as i speak, and scponly seems to be available on their local repository for wheezy. will try another package repository and see what happens.

getting similar scponly issues from other repositories. so have copied the scponly deb package from apt cache on the server which worked. and all good for now…

if anyone else is having issues… search for a deb package called scponly_4.8-4.1_amd64.deb on a search engine, then install it manually using dpkg -i BEFORE running

I had an install that worked but i had to do it in two times:

1/ run the install
=> fails
2/ remove ipv6 in the dovecot and postfix configuration
3/ run the install again
=> success

Dovecot and postfix are filled with ipv6 thing and as i have no ipv6 on the machine they fail to start and therefor prevent the install from working.

best regards,