Virtualmin and Usermin stuck to outdated version

I’ve got something like 10 servers with Virtualmin and Debian 9. Out of these, I’ve got 2 (dedicated vs 8 others being cloud) that show outdated Virtualmin (6.06-2) and Usermin (1.751) and at the same time " All installed packages are up to date" …
I tried playing with sources.list, comparing with cloud servers, I do not see what’s wrong with these 2, but at the same time I’m pretty sure there is a difference because they are the only 2 different from the others. I thought of completely replacing sources.list by one from the cloud servers but I’m afraid this could break something.
Any idea what could be wrong ?

Ok solved, sorry for the noise.
In case someone has the same problem: it was a pbm of rights on the /tmp folder, it was700 instead of 777 on other servers. Too bad Virtualmin does not give an error instead of “All installed packages are up to date”, I found out doing ssh into the server and a manual apt-get … this returns “Couldn’t create temporary file /tmp/apt.conf.qmthVm for passing config to apt-key” …

That is odd, as you should have gotten the following error message instead:

### Base temp directory /tmp is not world readable and listable

This is what I get, if I chmod 700 /tmp and reload the browser’s page.

Not here and I am not the only one: (in german but it’s the same problem).