Virtualmin and Almalinux from 9.3 to 9.4 except MariaDB

OS type and version Almalinux 9.4
Webmin version 2.111
Virtualmin version 7.10.0
Related packages MariaDB

Updated 320 packages, and the OS that now is Almalinux 9.4 (Coming from Almalinux 9.3) - Even if MariaDB is still 10.5.22 - Is there some extra option to do to have the DB updated to 10.11.x? Maybe enablig some package repositories?

Googled a bit, and it like there is a removal first, I guess that why its not upgrading.

That’s a feature not a bug.

When you pick one of the EL variants, you get a commitment from the OS provider that there will be no incompatible changes through the life of the distribution. The version of Mariadb that was in the release is what will be there in five years. They will backport security fixes, and some bugfixes. But, you can be almost 100% confident that software you deploy today will work unmodified throughout the life of the distribution.

If you start installing random versions, you lose that promise and that expectation. You also should not expect maintenance or security updates to be as active in any other version (though one could argue upstream packages will be pretty good on that front, they are also much more likely to break your apps or require dump/restores every now and then).

1 Like

They added the Maria 10.11 module stream to dnf for AlmaLinux 9.4, enabling an officially supported upgrade route.

Just run sudo dnf module install mariadb:10.11/server then sudo dnf update and it will upgrade you to 10.11.6. I ran the upgrade day before yesterday and it was quick and seamless. No need to remove first.

Don’t forget to then run mariadb-upgrade.


So you mean:
sudo dnf module install mariadb:10.11/server
sudo dnf update
and at the end:


It’s correct. Thank you @jdt1984 you solved the step.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.