Virtualmin 7.0.3 bug in installing php7.4

OS type and version almalinux9.1
Webmin version 2.013
Virtualmin version 7.5
Related packages SUGGESTED

I installed virtualmin 7.0.3,
and then followed the tutorial to install php74,

The php default is set to 7.4.33,
System Settings → Server Templates → Default → PHP Options

However, the new virtual server I created still has a default php version of 8.0.20

Not sure how it works in Alma, but a Debian maintainer has a repo that allows you do download multiple versions of php. I’m on the latest Virtualmin and it allows me to choose by server which one to use. But, yeah, it didn’t seem to work for me but I decided the software I was trying to install wasn’t worth the trouble so I didn’t go any further with it.

I think he is saying he has install it ok, but its not following the template settings to have php7.4 when creating a new server.

Yes. If I wasn’t clear, that was my experience. I only installed 7.4 for some software that asked for it. Checked it in the interface, but, when the package tried to install in complained it only saw the 8.x.

I just tested and works fine in Rocky 9.

Setting it in the interface worked fine for me too. Just made no difference to what the app saw. :wink:

Just tried it on a Ubuntu server the function works fine … must be a alma/rocky issue

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.