Virtualmin 6 - Debian 9 - Manage SSL - Intermediate Cert. - Error


Thanks for Virtualmin. It’s excellent.

I am having a problem installing an intermediate certificate using the Virtualmin interface. Here are the steps to replicate the issue:

  1. Add a new Virtualmin SSL website

  2. Go to Manage SSL certificate

  3. Add an intermediate certificate

  4. Either upload or paste the contents of the following file

  5. Virtualmin displays an error stating “Failed to save CA certificate : Invalid certificate file : Certificate does not appear to have a common name”

As I understand it, this certificate should not have a common name as it is a root certificate. The same thing happens if I try and use the AlphaSSL intermediate certificate as shown towards the top of

Or of course, I am being stupid!

I last used an AlphaSSL certificate with Virtualmin about a year ago and it worked fine then.

Hi, I have the same problem, have you found a solution please ?

I got that error and tried each root / intermediate certificates without success. Below is the way I solved the issue as apache was able to use the CA certs without issue.

Goto the edit directives on your SSL site. Ensure you have the SSLCACertificateFile pointing to . Now copy your PEM certs into that one file. If you more then one intermediate certificates paste them all in that file. Save the directives in Apache and apply the config in the up right corner.

SSLCertificateFile /home/mysite/ssl.cert
SSLCertificateKeyFile /home/mysite/ssl.key
SSLCACertificateFile /home/mysite/