Virtual servers not working after adding LetsEncrypt certificate

Server Information:

OS: Ubuntu 14.04
Web Server: Apache 2.4.7
Webmin: 1.900
Virtualmin: 6.04

What I have tried/done so far:

Initial attempt: Used certbot instead of the Virtualmin feature to add LetsEncrypt certificate. More info here: https://askubuntu.com/questions/1115202/internal-server-error-after-installing-letsencrypt-ssl-certificate-and-uninstall

Second Attempt: Manually remove /etc/letsencrypt folder and deleting all -le-ssl.conf files then retrying certbot. More info here: https://askubuntu.com/questions/1115487/403-forbidden-error-on-all-sites-after-adding-ssl-certificate

Third Attempt: Following the guide here: How to Use Let’s Encrypt SSL Certificate Automatically in Virtualmin / Webmin, I have managed to overwrite the certbot certificate that I initally tried adding with the Virtualmin generated certificate and also successfully redirected my site from http to https automatically. But now the error has changed from 403 to Internal Server Error 500 for this particular site. The other non-sll sites all redirects to the above site instead. Please help me.

Try subscription payd version?!

Then you have ticket support.

And https://www.virtualmin.com/buy/support is also a option. :wink:

@Jfro Thank you for the link!! I have purchased the Premium Support for one Incident just now. How do I use it now?

@Jfro I have opened a new issue just now here: https://www.virtualmin.com/node/64568

Is the above new issue using the purchased premium support?

Please that is all virtualmin support i am not working for them :wink:

And not allowed to see / open that link also.

and they:
Response within 24 hours

How to contact them using the purchased premium support? Please help.

Other time zone
and as printed: Response within 24 hours

@Jfro Thanks for helping me out man. I appreciate it.

Did they solved it?

It turned out to be a combination of multiple issues. But, we’re switching to certbot for new installs in a day or two (because wildcard certs aren’t supported by the mini client we currently use, and it needs to be updated, anyway), so we’re looking into making it a cleaner/clearer migration process.

1 Like