Virtual Server set up fails

Most virtual server set ups work fine but I run into random problems.

Once I had not tested that webmin could be restarted before attempting a set up. The set up process got to the step where it restarts webmin and it hung. I had to kill the set up. When I finally fixed it, I still could not add that domain that had errored out. It seems that VirtualMin actually begins to set up domains and if the process is not 100% successful it does not remove what it has set up. This causes a big problem because I have no idea what I need to do to delete all the settings for the domain that was partially set up.

What needs to be removed in order to start clean on a domain if the set up fails?


Sounds like a bug. A domain deletion should delete everything you tell it to delete (up to and including everything in the domain).

We’ll need to see the specific error you’re getting, as I don’t know what’s causing trouble here. Once we know where the trouble begins, we can begin to fix it.