Virtual domains not displaying from external pc's.

I’m running Lucid fresh install with the Virtualmin packages.

I added some other domains and I am able to see all of the content that I added via the browser on the server machine, but If I use a pc on the same lan it doesn’t propagate.

I’ve got nat, but it’s open, an even when it was closed, I was still able to see my machine. see below:

Machine is, it is visible externally, but the vhosts I added aren’t etc.

I tried to run the lan ip vs. the publicin the vhosts config via network-> edit config files, and it returned a 403 error for all of the pages both on the server machine and externally.

I’m stuck at this point as to what to try, and have double checked my DNS settings at the registrar, is there a template for those settings? As it stands now, I have tried, A name/Cname configs and then lastly pointed custom name servers for the primary and ns2 for the subsequent domains.

Thanks in advance for your help

Any help would be appreciated, I am still having issues with the dns resolving externally.



Well, there’s a variety of problems that could cause the behavior you’re seeing… common issues are DNS problems and firewall problems.

One thing you could try is to go to, and have them generate a DNS report for one of your domains.

Does it notice any problems?


I tried that earlier, and the report came back fine, it had an issue with one mx record, and something else that was irrelevant, I reset the router and again added the forwarding for the required. I’ll double check the firewall but I believe that it’s open.

With name-servers do I add the name-servers of the primary host to the v host, and also is beneficial to add the name-servers of the soa for the primary domain?

Thanks for the reply!


Well, if intodns isn’t showing an error, and the IP address you see listed for your domain in the intodns report is your correct external IP address – it’s probably not a DNS problem you’re having.

What error do you receive when trying to access your domain from a computer on an external network?

However, it may help for us to be able to see an example of a domain exhibiting this behavior. You can always edit your post once we get this working to remove the domain name from it.


It’s been posting a 404 error, I had tried to change the sites enabled and the other file sites ??? to the lan ip think that would help resolve the issue, but it popped out a 403 even on the server machine.

I just changed my dns from open dns to my isp’s default thinking that might help, for me lately, I’ve had issues with connectivity with dns not responding. I truly don’t think that alone is the root cause, but I’m kinda stumped. the primary machine web address is resolving and returning the same results in toolbox and, but the vhosts won’t open up.

Thanks again for helping out.


Well, if you’re getting a 404 error, and there’s a website uploaded to this domain – you may want to look at these docs here, in the section titled “the wrong site shows up”: