Viewing mail headers needs to have word wrap

SYSTEM INFORMATION
OS type and version RHEL 9.4
Webmin version 2.111
Usermin version 2.010

Usermin, viewing email, select View all headers and the right hand end of lines go off the screen but there isn’t a horizontal scroll bar (which I don’t like anyway).

Please add word wrap, it’s useless now being able to see full lines.

Hello,

I don’t see this issue happening in neither the Authentic nor Framed themes.

Could you elaborate on how to reproduce this issue? Could you PM me the email message in raw format (as a file) so I can try to reproduce the issue locally?

If you are a windows 10-11 user? Goto Settings > Accessibility > Visual effects
Turn on - Always show scrollbars

Your browsers will always have the scrollbars on.

I haven’t checked settings in Linux desktops but I believe Firefox has a setting for scrollbars.

It’s a browser issue. Happened to me until I changed my settings in browser and desktop.

1 Like

I don’t understand what we could do then? You mentioned the word wrap is missing, but I see it wrapping. Can you provide a screenshot?

This is the top of the header in an email. Without scrollbar always on setting in Browser or even OS like Windows, the header is cut off.

This is when View All Headers is clicked on.

The View raw message opens in another page with wordwrap just fine.

I have reproduced the issue. I will fix it in the next Authentic theme release.

Thanks for the heads up!

Great, I just found an example email too if you still need it.