Using pbzip2 in filesystem backup module

Operating system: Linux
OS version: Ubuntu 18.04.5 LTS
I am trying to speed up compressed backups. I would like to use pbzip2 as the compression, but this is not in the drop down list within the filesystem backup module.
I have installed Parallel BZIP2 v1.1.9 so this seems to be a recent enough version. I have restarted webmin and refreshed the modules. But it is still not an option in the drop down compress archive box.

This appears to be supported in virtualmin. Is it not supported in webmin as well?

Any help would be appreciated.

Best regards,


How about symlinking new /usr/bin/pbzip2 to /usr/local/bin/bzip2 and changing search path priority, by placing /usr/local/bin at the start of the PATH?

Have a look at Webmin > Webmin Configuration > Operating System and Environment page.

Thanks for the hint. I tried this but unfortunately it did not work. Any further suggestions?

… but it must work?! What is the output of :

which pbzip2

… and

which bzip2

… if what was said before is done correctly, then the last command output will point to bzip2 symlink.

You can test what is on the path by running :

echo $PATH

… from both in-built Command Shell (using Alt+K hotkey) (PATH is controllable from at Webmin > Webmin Configuration > Operating System and Environment page) and console (controllable by .bashrc file). Webmin considers its own environmental settings, even if system’s own search path is included (default).

Oh, I made a typo on the first comment (symlink pointer – corrected now). It should be the following:

ln -s /usr/bin/pbzip2 /usr/local/bin/bzip2

… and /usr/local/bin must be first placed first on the PATH.

Thankyou, this works perfectly. I did wonder if the symlink should be to bzip2 or pbzip2. I also made a typo I did not spot on the command line first time around which also prevented it from working.
It is all working fine now. Thankyou for the help.

Best regards,

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.