Usermin: mailbox often currupte because of 0 lengt messages

I have one mailbox that is often corrupted because of one, or several messages in it with zero length. Usermin can then not open that mailbox in most case, and if, can not delete those messages.

I have to remove them then with Webmin > Servers >Read User Mail and remove the [none] message(s) manually.

Strangely it’s in 95% of cases always the same mailbox. I have deleted and re-installed it already a few times.

Any clues where the error could be?

PS: I run CentOS with Postfix and Dovecot

PPS: While there is any zero message in the mailbox the mailbox can also not being accessed via pop 3. On my pop3 checker I can see there are 6 messages, but header can’t be downloaded and I get a “Server Failed” response.

PPPS: seems file attachment doesn’t work in this forum. I can see the jpg file when I edit, but not in the posted message. Anyway, it’s here:

I’d verify that you aren’t running into quota issues. I might also look in the logs, both /var/log/maillog and /var/log/procmail.log, to make sure there’s no errors listed in there.


Here is a procmail log error:

procmail: Quota exceeded while writing “/domain/homes/user/Maildir/.spam/tmp/”
procmail: Quota exceeded while writing “/domain/homes/user/Maildir/tmp/”
procmail: Quota exceeded while writing “/domain/homes/user/Maildir/tmp/”

I have raised some quota to “unlimited”. Let’s see what happens now. That user in question was before 51200, but the mailbox was almost empty with less then 10 text messages.

I will watch it for the next few days.

I think I had memory problems. Since I had another problem with YUM sometimes not working I had a look here:

I did:

ls -l /var/lib/rpm
rm -f /var/lib/rpm/__db*
rpm -vv --rebuilddb
yum clean all

Not sure what it did, but Yum worked after that and memory consumption is much lower now.