Usermin Login: Permission denied


I installed virtualmin on my new server and transferred some domains from cpanel with migration utility. Everything over great except for usermin. When I try to login to usermin, I get this error:

Failed to create /home/user1/homes/support/.usermin : Permission denied

No matter what permissions I give to support folder; what ownership I give to that folder, error remains the same. I tried owner as support.user1:user1,user1:user1 and permission as 777 as well.

I have been wasting a lot of time figuring out what is happening to this. If anyone can figure out the problem it will be really helpful. Thank you.

Vishnu N


Hmm, that’s an unusual!

First, you may want to go into Limits and Validation -> Validate Virtual Servers -> Fix Permissions, and have Virtualmin correct the permissions on that account.

After doing that – do you still have the problem?

If so, there’s two questions I have –

First, do any errors show up in /var/usermin/miniserv.error?

And second, are you able to log in as that user using a different email client, such as Outlook or RoundCube? You may want to verify that you can create and delete emails once you log in.


Thank you for your reply. Another thing that might help in debugging is that the usermin I am trying to log in is a subserver of user1 and these domain where migrated from cPanel.

Validate Virtual Servers:
Tried that and for couple of my domains I am getting errors like these:
Mail for domain : Home directory /home/user1/public_html/c/admin for user subuser1.user1 is owned by user1
But this error does not appear for the subserver that I was trying to troubleshoot. What is confusing is that public_html/c/admin is just a content directory. Why is virtualmin checking that folder’s permission against email.

Fix Permissions:
Tried and it shows “Fixing file ownership and permissions for … … done” but again if I execute validate servers, I get the same errors.

Usermin error log:
In error log, when I try to login, this error appears (same as displayed when I try to log in to usermin): Error: Failed to create /home/user1/homes/support/.usermin : Permission denied
But another thing I noticed:

[03/Jul/2013:05:46:38 +0200] started
[03/Jul/2013:05:46:38 +0200] Using MD5 module Digest::MD5
[03/Jul/2013:05:46:38 +0200] Perl module Authen::PAM needed for PAM is not installed : Can’t locate Authen/ in @INC (@INC contains: /usr/libexec/webmin /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 15) line 1.
BEGIN failed–compilation aborted at (eval 15) line 1.

[03/Jul/2013:05:46:38 +0200] Reloading configuration

So I tried installing Authen:PAM (Webmin > Perl Modules > CPAN) and I get this error:
Installing package(s) with command yum -y install perl(Authen::PAM) …

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • remi:
    Setting up Install Process
    No package perl(Authen::PAM) available.
    Error: Nothing to do

… install failed!

I tried again and I got (while compiling):
Executing /usr/bin/perl Makefile.PL && make …

Checking if your kit is complete…
Looks good
checking for gcc… gcc
checking for C compiler default output file name… a.out
checking whether the C compiler works… yes
checking whether we are cross compiling… no
checking for suffix of executables…
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking for gcc option to accept ANSI C… none needed
checking how to run the C preprocessor… gcc -E
checking for pam header files in… no
configure: error: cannot find the pam_appl.h file
Error in configuring the Authen::PAM module.

Using email client:
I am not able to login using any email client

Thank you.

Vishnu N


What error(s) do you get while trying to log in using another email client?\

You can see any errors being produced in the email logs – that’s either /var/log/mail.log, or /var/log/maillog, depending on your distro.



This is the error that I get when I try to login via an email client:

Jul 3 15:03:27 rs206409 dovecot: pop3-login: Aborted login (auth failed, 3 attempts): user=<support.wina>, method=PLAIN, rip=::1, lip=::1, TLS


I am still facing this issue. For now I am managing this by forwarding emails that I get here to another email id. But this has to be corrected. Any help anyone…

Thank you.

Vishnu N