Usermin error?

When I send email from Usermin I get the following error:

Failed to send mail : SMTP command rcpt to: failed : 554 5.7.1 : Relay access denied

The only thing I can think of is I changed the port for Virtualmin and Usermin for security, other than these changes it is a default install of CentOS 6.4 64bit.


Do you get that error sending email to any user? Or does that occur for one user in particular?

That almost sounds like a Postfix configuration issue… what output do you receive when you run “postconf -n”?


That’s for any email address.

Here is the output of postconf -n

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
allow_percent_hack = no
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
home_mailbox = Maildir/
html_directory = no
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
mailbox_size_limit = 0
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost,
mynetworks =
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
sample_directory = /usr/share/doc/postfix-2.6.6/samples
sender_bcc_maps = hash:/etc/postfix/bcc
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
unknown_local_recipient_reject_code = 550
virtual_alias_maps = hash:/etc/postfix/virtual


Ah, it looks like localhost was removed from the Postfix “mynetworks”.

That would make it so Postfix would reject connections coming from your server.

What you’d want to do is edit /etc/postfix/, find the “mynetworks” setting, and add this to the end of that line:

It should look something like:

mynetworks = x.x.x.x,

After that, restart Postfix, and then see if you’re able to send email from Usermin.


Thank you!

That worked.