Usermin, delete button on mail list stopped working

OS type and version Redhat Enterprise Linux 9.3
Webmin version 2.105
Usermin version 2.005
Virtualmin version 7.8.2 Pro and GPL
Theme version 21.09.5

I noticed a couple of days ago that the delete button on top of the mail list had stopped working.

I just verifed this with both Pro and GPL versions.

I see an uncomfortably long delay before the message is deleted (which is also a bug-like), but it does work for me.

So, if it really never deletes (even after 5-10 seconds or so), we’ll need to see the errors from the browser console, I think. We also need to know what browser you’re using.

I’ll ask @Ilia to drop in here, as this is on his plate.

This is curious. It only happens if there aren’t many emails in the list, doesn’t seem to matter how old they are or how old the account is.

It doesn’t do anything, the blue tick just sits there - I waited 30 seconds. No errors.

Using Firefox on Win10, both up to date.

I tested on an account with 10 emails, ticked one, hit delete and got nothing.
I then set it to move to trash instead of just deleting and it started to work.

Setting it back to actually delete and it still works.

Tested on another account this time on GPL server and after failing I went to preferences, did a save without making any changes and it now works.

Another test on the Pro server, account had 30+ emails, I deleted a handful leaving 26 and now it has stopped deleting.

Preferences set to show 25 so it’s not because of only being on one page.

I can confirm this issue.

But for me it only happens on first use of the usermin account. AND when attempting to delete more than one email.

When I open the email the delete button works as expected. When I return to the list the delete button “trash icon” works as expected deletes all selected emails.

it is as if opening an email throws a flag and gets everything to work.
not browser dependent (Chrome & Firefox)
no errors in dev tools, can wait for ever, does seem to be transient and only on first use. (again suggesting a flag is not initialised when inbox is first loaded with its list)

I can log in to en existing account, delete from list not working. Read an email, return to list and then delete works.

Logout, then log back in again - same problem.

It doesn’t matter how many or few emails I select. Just one or the who;e page list.

That is odd. I have 1k emails in my inbox and I could list and then delete those super quickly without any issue:

@Randomz I’m surprised that you’re having this issue with Usermin 2.005. Did you try another browser in incognito mode? Did you try restarting all related services (or just rebooting the server)? Also, did you change any mailbox related options for Usermin in Webmin → Usermin Configuratoin page? Is Usermin connecting via IMAP or reading Maildir directly? How large your emails are?

@Ilia 2.005 here as well.
I have just done a reboot (and refilled the inbox) - problem is still there.
This is not browser related I have now tried Brave and in desperation (IE) still the trash icon does nothing until I open a message then I can use it to delete as many as are selected. → initially the selection is not activating the trash can icon?

going to try same on a different box different domain/email.

It is not a desperate problem to fix as opening the message then deleting it still works so AFAIC it can wait.

Does the following solve the problem — before trying to delete messages try to hit on the left menu, choosing specific inbox? For example, clicking on Inbox in navigation menu before selecting messages for deletion and hitting Delete button?

If it doesn’t, can you open browser’s console, with Network tab in view, try the operation (select and delete emails) and then see if there are any error messages printed there? If there are, can you take a screenshot of the whole page, including left menu and share it with me?

Sorry about slow response → was called out of office.
On a different VS (but same VM) Still Ubuntu OS Usermin 2.005 I get console errors:


I believe the issue might come from not having any mailboxes actively selected?

Could you try clicking on the Inbox link in the left navigation menu to see if it resolves the deletion problem then? If this fixes the issue, it still indicates a bug, though a different type than initially thought…

1 Like

That worked for me. Can’t delete when first logged in. Click the inbox on left and then I can delete.

Yes, that seems to fix it - click and wait for the candy stripes to complete, then select the email to delete, click on the trash can icon and it deletes it

@stefan1959 and @Stegan, are you guys running the latest Usermin 2.005? Can you confirm that this issue can be reproduced in incognito tab as well, and right after logging in to Usermin? Or how did it happen for you exactly?

Does it always require to click inbox link in navigation? I’m having troubles reproducing it. Also, I remember fixing this (and similar) issue in the past. Does it change anything if you force reload the browser’s cache by clicking Ctrl+Shift+R?

@Randomz Does it also solve the issue for you? Or your initial issue was different, i.e. slow email deletion? @Randomz is Usermin connecting to the mailbox using IMAP or it reads Maildir directly?

Yes running Usermin 2.005
Authentic theme 21.09.5

Same error with Incognito

exact steps are:
1 Log in to Webmin/Virtualmin as root
2 select VS
3 go to Edit Users
4 select my user name (edit user)
5 click button to login to Usermin
6 select (tick) a single email to delete (DO NOT OPEN IT) this reveals the trash can icon
7 click the trash can → error in console (nothing on the gui)

then if I choose “Inbox” AND wait for the candy stripes to finish then repeat 6 above the trash icon does the delete.

then close the window and reload as 1-5 → exactly the same

Ctrl+Shift+R → no change

Alright, thanks for the heads up. I have made a patch on the theme side. It should be fixed now.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.