Usermin connection error

Hi,

I’ve just installed Virtualmin and created my first Virtual server. I can login to virtualmin for the new virtual server (on port 10000), but whenever I try and access usermin for a user on the new virtual server I get a Page Load Error in my browser. The full browser error is

"The connection was refused when attempting to contact "my-domain":20000.

There are no errors in the usermin miniserv.err file and I can see stuff listening on port 20000 by using lsof -i :20000. Connection’s on this port are simply refused - point blank!

I’ve even tried re-installing.

Any ideas?

Thanks

Daz

There isn’t by chance a firewall or router in there causing some problems, is there?

What if you log onto your server over SSH, and type:

telnet localhost 20000

Does it connect (and just kind of hang there), or do you immediately receive a connection refused message?
-Eric

Hmmm, interesting

If I ssh onto the box and telnet localhost 20000, I can then type "get index.html" and get an HTTP error back from miniserv.pl. BUT if I then "telnet my-virtual-server.co.uk 20000" from my box at home I get a connection refused. However it works to port 10000 (webmin/virtualmin?). So, something is blocking access to port 20000 from remote hosts?

I’ve flushed all the IP tables firewall rules just to make sure but I still get the same problem.

My router firewall doesn’t seem to be blocking, could my ISP be blocking this port? Is there a way to know for sure?

Thanks

Daz

What’s the output of:

iptables -L -n

You don’t by chance have another server or box somewhere that you can log into and run a test from, do you? That’d be a great way to find out.
-Eric

iptables -L n on the virtualmin box shows:

iptables: No chain/target/match by that name

I’ve used nmap to scan port 20000 on the virtualmin box from another host and it shows the port as being closed. If I run the same command on the localbox it shows the port as being open. However, I’ve tried editing the /etc/usermin/miniserv.conf file and changing the port to say 9999 and restarting usermin with no effect i.e. still closed.

I’ve even switched off xinetd in case there was a service defined there that was blocking port 20000.

Is there any host based autentication for usermin that could be preventing access from remote hosts. (I’ve check tcp wrappers /etc/hosts.deny etc and that’s clear).

Help :frowning:

One thing I forgot to mention is that this box had Plesk on it before I unstalled Virtualmin. However, I un-installed Plesk (following the uninstall instructions in the admin manual) before installing virtualmin.

All rather puzzling!

Regards

Daz

If I stop webmin and then start usermin on port 10000 it works! but I can’t get it to start on port 20000 (or any other random port that I tried).

I’m changing the “port” and “listen” parameter in /etc/usermin/minserv.conf to change the port that usermin is listening on. I’m not sure if this correct though?

iptables -L n on the virtualmin box shows

Almost… there’s a “dash” before both of those options:

iptables -L -n

I had already flushed the rules in case there was a dodgy rule somewhere, but here’s what I see:

iptables -L -n
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

I had already flushed the rules in case there was a dodgy rule somewhere

Yeah, not everyone is as savvy as yourself.

Some people say "I flushed the firewall rules", and you later discover that they meant was "I washed out the inside of my car" :slight_smile:

Okay, I’m guessing that there may be an issue with some sort of router/firewall outside of your box.

You’re not by chance running this server on a NAT’d connection, are you? If so, make sure you have port 20000 forwarded from your router into your server.

Otherwise, it could certainly be your ISP blocking the ports.
-Eric

If I stop webmin and then start usermin on port 10000 it works! but I can't get it to start on port 20000 (or any other random port that I tried).

Does it actually not start? Everybody’s talking about firewalls, but if the darned thing isn’t running, we’re not going to have anything to on the other side of the firewall anyway.

Are there any errors when starting? In the /var/usermin/miniserv.error or miniserv.log logs?

Forgive me if this has been covered. I’m just blasting through dozens of threads lending my idiotic opinions quickly and without paying much attention to what’s already been said.

I’m pretty sure that it is starting. Here’s some proof (I hope):

lsof -i :20000
COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
miniserv. 14123 root 5u IPv4 330446 TCP *:dnp (LISTEN)
miniserv. 14123 root 6u IPv4 330447 UDP *:dnp

cat /var/usermin/miniserv.error

[24/Jan/2009:22:25:07 +0000] miniserv.pl started
[24/Jan/2009:22:25:07 +0000] PAM authentication enabled

All sorted now! (My dedicated server host has a very restrictive list of ports that they permit through their firewall - needless to see port 20000 was blocked so I changed usermin to listen in on one of the permitted ports).

Thanks for all your excellent advice and help.

Regards

Daz