User-configured mail forwarding not available in usermin

OS type and version: CentOS Linux 7.9.2009
Webmin version: 1.981
Virtualmin version: 6.17 Pro

Hi all,

I’m in a bit of a panic because one of our best customers is bending my ear, a lot.

I have transferred this client from an old Centos 5 box which had User-configured mail forwarding The user was deacked up and restored on the new box but email has not been forwarded, it just sits in the mailbox. I have checked that the forwarding is still set using Edit Users and it does show that the condition and action is set.

I thought that it could resolve the issue if I removed and reset the forwarding in Usermin but the option to filter and forward is not there. I have also checked other users in a different domain and find that it is not shown in any of them.

I have checked that "Filter and Forward Mail " is selected in Webmin > Usermin Configuration and it is.

Is there anywhere else that controls whether or not the ability to forward email is allowed in Usermin?

I prefer to use user configured forwarding because that happens after the spam filters (uinless that has changed).

I would appreciate any help anyone can offer.

Thanks for reading.

Oops !

I have found the user configured forwarding now. Sorry to waste your time reading.

Now I just have to solve why mail is not being forwarded.

1 Like

Try checking /etc/alias and /etc/postfix/virtual if the forwarding is set correctly on those files.

The most simple work-around would be is to go to Edit User page and toggle forwarding by first disabling, saving and then re-enabling it.

If it’s still doesn’t work, double check if /etc/aliases.db and /etc/postfix/virtual.db files are getting regenerated, otherwise regenerate them manually by running:

postalias /etc/aliases
postmap /etc/postfix/virtual

… also check if maps are configured expected way. You could list all set maps by running:

postconf |grep -E '_maps = [a-zA-Z]'

Thanks Ilia,

I did remove and re-add the forwarding in Usermin and that seems to have fixed it.

Now I have to forward the hundred or so emails that should have been forwarded. In passing, is there an easy way to place those emails back into the queue so that they are forwarded in the normal way or must I manually forward them all using Usermin? Doing it manually does not maintain the senders address etc. of course.

I will also have to go through all the other accounts but that is another story which I can sort out.

It is rare that strange issues like this occur with VM, so no complaints from me.

Many thanks for your ongoing support.
Tim