User Can't Change his own Password

OS type and version Ubuntu Linux 22.04.2
Webmin version 2.101

I have recently created some Users under Webmin/System/Users and Groups.
I have added them in a group.So far so good.When i try from the user perspective to change his own password i get the following error : Failed to save user : you cannot deny yourself access to the Webmin Users module .
I have tried changing the permissions on the module that the Group has rights but nothing works.Done some multiple testing and whatever permission i give the same error occurs.
Any guidance will be appreciated.

Best Regards

What hsppens if the user changes their password using usermin. I always point users there as there is no messing with webmin modules just works out of the box

In my case this is not a viable option.There is a great number of users so this will take too much time.

exactly what are you trying to do ? Change all user passwords without user interaction or something else ?

I am trying to give to some normal users from the Webmin the right to change their own password.
But it seems that this doesn’t work.

That’s why you use usermin just get the user to login on yourdomain:20000 instead of 10000 there they can change their password … not time consuming at all

Usermin doesn’t come with Webmin, but it can be added.

I just had a play with this, it’s very good.

In Webmin select Unused Modules, Usermin Configuartion, Install Usermin.

For Redhat variants add port 20000 to Firewalld, not sure about Ubuntu.

In Webmin select Webmin, Usermin Configuration, Available Modules and untick everything except Change Password.

Go to User Interface select yes for Go Direct to module if user only has one.
Then select Change Password in After login, always go to module - might not be necessary.

Save and Restart Usermin - might not need to be restarted.

With a bit of fiddling you could even create a DNS entry eg which would go straight to it.

If you’re doing this just to allow users to change passwords in a web UI and you don’t want any of those users to have root access to anything on the system, Usermin is the right tool for the job.

If you’re doing this for users that should have root access to stuff, then I’m confused how you’re getting that error.

How are you changing the password as the user? I mean, specifically what is the module you’re using? (Webmin Users should not be coming into play at all for a system password change. Webmin user paasswords are not system user passwords, and most people should not be using Webmin user passwords at all…letting Webmin authenticate with system users is the most sensible thing in most cases, for a variety of reasons.)

Usermin is doing the trick yes.I will try these steps also you provided.

I am not giving them root access.I was just wondering why it is not a feature from the Webmin.The module i used was from System/Change passwords.But the Usermin can solve this issue.So i will try this.Thank you.

Thank you very much.