Use fcgid instead of mod_php


i am running virtualmin on centos with php7.3 and laravel installed.

And under server configuration->website options was mod_php enabled. After a bit of reading I tought it is an option to remove/disable mod_php.
Now mod_php is not listed under server configuration->website options, but if I go to server-configuration->php versions, it says mod_php is installed.

website options screenshot (imgur)

php versions screenshot (imgur)

I am a bit confused, maby someone can help me.


You don’t remove “mod_php”, you simply switch the mode being used. In a fresh CentOS 7 install you typically have “mod_php”, “CGI wrapper”, “FCGId” and “FPM”. Simply toggle the execution mode you would like to use for the domain.

yeah, that was the problem. I was trying to switch… between mod_php to fcgid and all worked fine. Virtualmin says it is done, but when I go back to server configuration->website option the checkbox is still at mod_php and the same at server configuration->php versions still says mod_php is enabled.

It is only on my first virtual server, don’t know, if laravel needs mod_php. But my two other virtual servers are working with fcgid.