[URGENT] Help for setting up domain under webmin/virtualmin

Hello, i’ve finally come into posting these after several weeks of troubleshooting on my new linux vps with both webmin and virtualmin 3.94.gpl installed.

I am a newb in linux and of course very new to webmin/virtualmin.

All i want is to add a domain into my server and start publishing simple webpages.

Heres what ive done,

I have pointed my domain from namecheap.com to the dedicated nameservers (NS1.mydomain.com/NS2.mydomain.com) with a single ip given by vps host.

Now, i setup and install webmin/virtualmin and landed onto default apache/centos page through or http://NS1.mydomain.com or http://NS2.mydomain.com

Have also successfully logged into the virtualmin page @

OK. Everything good so far has been done.

I carried on to add a virtual server, from reviewing guides i could find to add my domain name “mydomain.com” into the “Create new virtual server”…

All created successfully and able to view my domain http://mydomain.com/

My main problem here is that i am only able to view .html but not .php! Don’t understand why everytime i tried to locate a simple .php extension file like “http://mydomain.com/index.php” it gives me a

503: Service Temporarily UnavailableThe server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. Error after loading for a couple of minutes.

However, http://mydomain.com/index.html works completely fine.

Some info on the servers are as follows:

Operating system CentOS Linux 6.3
Webmin version 1.590 Virtualmin version 3.94.gpl GPL
Theme version 8.5 Time on server 15/Sep/2012 15:01 , Up 0 hours, 56 minutes
Kernel and CPU Linux 2.6.32-042stab057.1 on x86_64 CPU load averages 0.00 (1 min) 0.02 (5 mins) 0.02 (15 mins)

Please help!

Did you check the log files of your webserver? Please post the error messages here.

These are the 2 error logs i seen when accessing the .php file.

[Sun Sep 16 06:34:07 2012] [error] [client ] File does not exist: /home/mydomain/public_html/favicon.ico
[Sun Sep 16 06:35:13 2012] [warn] [client ] mod_fcgid: can’t apply process slot for /home/mydomain/fcgi-bin/php5.fcgi

What are the permissions of that fcgi-bin folder and the file inside?


I’m curious what happens if you go into Server Configuration -> Website Options, and you set the PHP Execution Mode to “CGI”. Sometimes CGI can produce better error messages.

Also, what kind of VPS are you using… is it by chance OpenVZ? If so, can you post your /proc/user_beancounters file?



And forgot to mention, what errors are in your suexec log in /var/log/httpd?

@andreychek, i tried ur method and im using OpenVZ, it works.
I am changing it to
Apache mod_php (run as Apache’s user)

From a list of available options here:
Apache mod_php (run as Apache’s user)
CGI wrapper (run as virtual server owner)
FCGId (run as virtual server owner)

Thank you and helpmin for the assist! I can now start installing my wordpress blog…