Upgrading Virtualmin

I am on CentOS, and Virtualmin 3.78. Would like to get 3.80.

I’ve tried yum update wbm-virtual-server, and yum install wbm-virtual-server, to no effect. I believe that the latter is what’s on the Doc page.

I’ve got a virtualmin.repo in yum.repos.d, and it points to software.virtualmin.com, which sounds pretty good as a repo name.

Is this enough info? Please advise on the upgrade process. Thanks!


How did you initially go about installing Virtualmin, did you use the install.sh script?

Also. what do you get if you type this command: rpm -qa | grep virtual-server



Man, so long ago…It’s Pro, so does that make it more likely to have been done via the install.sh? Why is that important?

Here’s the result of that rpm command:

What do you make of that?


Yeah, that definitely looks like you have the RPM… so if you run a plain “yum update”, it should show what repositories it’s hitting as it’s updating your system. Do you see any errors or warnings when it sees Virtualmin’s repositories?

Also, if you look at this URL:

http://virtualmin.com/serial/, do you see any problems with the license you’re using for this particular server? Any red errors or warnings on the screen?


Hey, I am not excited about “yum update” - that is like an open invite to any installed repo to install whatever it thinks is newer? Including PHP 5.3 - which still seems to have a blocker issue, that Zend hasn’t released decoders for Zended files? If I do that update, I think I want to exclude 5.3, at least…

There are no errors on the serial page, nor any showing on the License panel on the frontpage of Virtualmin.

I am having an issue with redirects not working, and I want to get up to the latest version before I post it.

Is there a workaround for today? Could you consider posting the manual upgrade procedures to the Doc? I’d like to get this one little thing done.

Thanks, Eric.

It sounds like something may be wrong with the setup or configuration of the Virtualmin repository, though it’s difficult to know exactly what the issue is.

Also, I personally would not add a repository to your server unless I wanted all the packages installed in it on my server… if you don’t want all the packages from a repository, you could make use of the includepkgs and excludepkgs config options within the .repo file to include or exclude the packages you want.

Otherwise, it becomes near impossible to keep your system up to date :slight_smile:

However, as far as getting the latest Virtualmin – you can always browse to the repository using a web browser and manually download the latest version:


The repo download area is passworded. Is the username and password related to my license key somehow? I tried the serial and license keys in both fields, no joy.

Yeah, the serial number is the username, and the license key is the password.

If that’s not allowing you to log in, that could certainly explain the issue you’re seeing!

When you look at virtualmin.com/serial/, when does it say your license expires?



Ok, maybe I fat fingered it the first time. I am logged in…Thanks!

Since you are such a sport: Does it matter where I wget save the rpm? I just created /root/rpms

Then how to install? rpm -i produces errors like “migration-psa.pl from install of wbm-virtual-server-3.80-1.noarch conflicts with file from package wbm-virtual-server-3.78-1.noarch” - --force argument for rpm? I won’t try that without an OK, as the book says "And like a big hammer, it pays to fully understand why you need to use --force before actually using it. "- Please confirm.

For those following along at home, or at work, in their vehicle, someone else’s vehicle… see http://www.cyberciti.biz/faq/wget-command-with-username-password/ for wget syntax, if needed.

Thanks again.

Rather than “-i” (which is “install”), try it with “-U” for “upgrade” – that should do the trick!


Success! Thanks for the patient guidance.