Upgrading to the latest version of Virtualmin GPL


I am running Virtualmin 3.76.gpl GPL. While the news section shows 3.81 was released a few weeks ago.

Is this upgrade also available for the GPL version?

The sytem Information does not show any upgrade available.


How do I upgrade if an update is available?


How did you do the initial installation? Did you use the install.sh script?

If so, there should be a few options you can use for upgrading Virtualmin… which distro are you using? One of the easiest ways is to just type “yum update” or “apt-get update && apt-get upgrade” on the command line.

You should also be able to do all that from within the Virtualmin GUI, but I’d be curious if those other options work for you… as if they don’t work, nothing would work :slight_smile:


OS: CentOS Linux 5.3

Yes I had used install.sh script to install it. A yum update would upgrade everything to the latest versions. Which is not what I want.

Did you see the link in my previous post? I dont see a Virtualmin server upgrade there.

How do I manually upgrade just virtualmin ?

Thanks for the quick reply.

Yup, I saw the link in your post… it’s difficult to tell why that would be the case, running the “yum update” would show if it’s a system issue, or a Virtualmin issue.

As a whole, we’d certainly recommend keeping your CentOS packages up to date :slight_smile:

However, to just update Virtualmin, you can also just type something like:

yum update wbm-virtual-server

Does that command allow you to update Virtualmin?


Manual update with yum update wbm-virtual-server worked flawlessly.

I tried doing a yum update to update centos packages.

There was an error

drbd-8.0.16-5.el5.centos.x86_64 from extras has depsolving problems
–> drbd conflicts with drbd82
clamav-filesystem-0.96.1-1.vm.el5.x86_64 from virtualmin has depsolving problems
–> clamav-filesystem conflicts with clamav
Error: drbd conflicts with drbd82
Error: clamav-filesystem conflicts with clama