Upgrading Dovecot to 2.3.20

SYSTEM INFORMATION
Rocky Linux 9.3
7.9.0 Pro

Has anyone had success upgrading their dovecot and postfix install on Rocky 9 machine using the Ghettoforge

https://rhel.pkgs.org/9/ghettoforge-plus-x86_64/

Im wanting to upgrade as im running Imunify360and it doesnt support the stock 2.3.16 but it will the 2.3.20

i tried just through the software updates and it screamed at me with this, so just trying to see if someone has done this and just backed up the config files.

Transaction test error:
file /etc/dovecot/conf.d/10-mail.conf from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /etc/dovecot/conf.d/10-master.conf from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /etc/dovecot/conf.d/10-ssl.conf from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /etc/pki/dovecot/dovecot-openssl.cnf from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/bin/doveadm from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/bin/doveconf from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/bin/dovecot-sysreport from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib/systemd/system/dovecot.service from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/auth/lib20_auth_var_expand_crypt.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/auth/libauthdb_imap.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/auth/libauthdb_ldap.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/auth/libmech_gssapi.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/dict/libdict_ldap.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/doveadm/lib10_doveadm_acl_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/doveadm/lib10_doveadm_quota_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/doveadm/lib20_doveadm_fts_lucene_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/doveadm/lib20_doveadm_fts_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/doveadm/libdoveadm_mail_crypt_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib01_acl_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib02_imap_acl_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib02_lazy_expunge_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib05_mail_crypt_acl_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib05_pop3_migration_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib10_last_login_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib10_mail_crypt_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib10_quota_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib11_imap_quota_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib11_trash_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib15_notify_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_charset_alias_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_fts_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_listescape_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_mail_log_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_mailbox_alias_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_notify_status_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_push_notification_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_quota_clone_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_replication_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_var_expand_crypt.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_virtual_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib20_zlib_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib21_fts_lucene_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib21_fts_solr_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib21_fts_squat_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib30_imap_zlib_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib90_old_stats_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib95_imap_old_stats_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/lib99_welcome_plugin.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdcrypt_openssl.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdovecot-compression.so.0.0.0 from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdovecot-dsync.so.0.0.0 from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdovecot-fts.so.0.0.0 from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdovecot-lda.so.0.0.0 from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdovecot-ldap.so.0.0.0 from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdovecot-login.so.0.0.0 from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdovecot-sieve.so.0.0.0 from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdovecot-sql.so.0.0.0 from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdovecot-storage.so.0.0.0 from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdovecot.so.0.0.0 from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libdriver_sqlite.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libfs_compress.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libfs_crypt.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libfs_mail_crypt.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/libssl_iostream_openssl.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/old-stats/libold_stats_mail.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/lib64/dovecot/old-stats/libstats_auth.so from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/aggregator from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/anvil from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/auth from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/checkpassword-reply from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/config from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/dict from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/director from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/dns-client from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/doveadm-server from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/dovecot-lda from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/gdbhelper from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/imap from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/imap-hibernate from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/imap-login from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/imap-urlauth from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/imap-urlauth-login from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/imap-urlauth-worker from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/indexer from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/indexer-worker from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/ipc from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/lmtp from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/log from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/maildirlock from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/old-stats from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/pop3 from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/pop3-login from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/prestartscript from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/quota-status from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/rawlog from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/replicator from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/script from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/script-login from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/stats from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/submission from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/submission-login from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/libexec/dovecot/xml2text from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/sbin/dovecot from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/share/man/man1/doveadm-auth.1.gz from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/share/man/man1/doveadm-director.1.gz from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/share/man/man1/doveadm-kick.1.gz from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/share/man/man1/doveadm-penalty.1.gz from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/share/man/man1/doveadm-proxy.1.gz from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/share/man/man1/doveadm-pw.1.gz from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/share/man/man1/doveadm-replicator.1.gz from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/share/man/man1/doveadm-stats.1.gz from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/share/man/man1/doveadm-sync.1.gz from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/share/man/man1/doveadm-user.1.gz from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64
file /usr/share/man/man1/doveadm-who.1.gz from install of dovecot23-1:2.3.20-3.gf.el9.x86_64 conflicts with file from package dovecot-1:2.3.16-10.el9.x86_64

Thanks in advance

You should normally wait for upgrade release from Rocky repos or do it on development machine.
I guess you using a rpm install, try upgrading it via a extra repo like this one.
https://rhel.pkgs.org/9/raven-extras-x86_64/dovecot-mysql-2.3.20-1.el9.x86_64.rpm.html

Here is the install instructions for the repo
https://www.simplified.guide/redhat-centos-fedora/repo-raven-install

But I would be doing this on a development machine to make sure nothing breaks.

Opps, I just noticed that was dovecot-mysql

but I see it in the list
https://rhel.pkgs.org/8/raven-extras-x86_64/

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.