Upgrade Ubuntu 18.04 to 20.04

Ubuntu:
18.04.4:

Hi, Is there currently an official guide on upgrading from Ubuntu 18.04 to 20.04? I’ve found a few going from 14 > 16, and 16 > 18, but no further.

I gather I SSH into my VPS and run the standard update commands, but is there anything else beyond that? Or is it considered ‘better’ to install on a fresh OS? My current VirtualMin install is my dev sandbox, so not earth shattering if starting clean is best. At some point I may look to replace my WHM/cPanel production server with VirtualMin, so just curious what my options for upgrading the OS and having VirtualMin continue to work are.

Thanks for your time.

I too have the same concern. Although, I would prefer not to require a fresh start when upgrading from Ubuntu 18.04 to 20.04.

So I tried the do-release-upgrade option, and kept all the previous configurations same, but ran into a problem (thankfully I had kept a snapshot ready to be restored in case I ran into any problems). Apparently, having DNSSEC enabled messed up the easy upgrade path. Will turn off DNSSEC for the few domains I have and try again tomorrow.

So I successfully upgraded from 18.04 to 20.04.

  1. In your BIND configuration, comment out dnssec-enabled yes line. This won’t disable DNSSEC, BIND 9.16.0 is a bit different.
  2. Run: do-release-upgrade
  3. Keep all config files the way they are. Press N to all changes (default).
  4. After the install is finished, press y to restart server.
  5. Edit /etc/apt/sources.list, and uncomment the Virtualmin repositories. Then change any references of bionic in those repositories to focal.
    Run this command, and make sure the new apt config works properly:
    apt-get update
  6. Verify DNS Config Edit /etc/resolv.conf, and verify that the nameserver line is configured to use your loopback address as a nameserver.
  7. Manually edit OS version: Webmin > Webmin Configuration > Operating System and Environment - Set Operating system according to Webmin to the detected version.
  8. Run: sudo update-grub and reboot after
  9. Now, log into Virtualmin, and go into System Settings -> Re-Check Config, and verify that it doesn’t detect any problems.

If Postfix tells you that sender specific mapping is not defined, change that and enter this in Mapping Specification: hash:/etc/postfix/dependent.

This should upgrade your Ubuntu server correctly. But I am experimenting with this too, so let me know if any problem arises.

1 Like