upgrade mysql 5.7 to 8

Hello Team,

is there any official way to upgrade mysql server 5.7 to 8…???

or any one tried and succeeded with this experiment??


Sorry, there aren’t any supported ways to upgrade to MySQL 8.

Virtualmin just makes use of the packages included with your distribution, and there aren’t any distributions shipping with MySQL 8.x yet.

In general, we don’t recommend using packages from third party repositories, as we’ve seen a lot of issues come up when doing so.

That said, someone who’s recently tried that anyhow found that there’s some issues with MySQL 8 that aren’t fully supported. We’ll work on that, but we unfortunately don’t have an ETA for those fixes.



Hello Eric @andreychek
I have a new box where i had done most work and i had default mysql presumably mariadb 5.6 or 5.5 I followed some instructions on installing mydql 8. I removed mariadb but it seems it dnt really erase all. When i try to install mysql 8
the following error shows that mariadb did not uninstall. CAN YOU guide where is the REPO or any reference of default mariadb mysql to disable it temporarily to allow mysql 5.7 or 8 to be installed to see if it works. I have looked everywhere but i cant seem to find in yum/repos.d
In brief how can we uninstall mariadb on the system and then later reinstall if nothing works.

Installing : mysql-community-client-8.0.12-1.el7.x86_64 3/5 error: %pre(mysql-community-server-8.0.12-1.el7.x86_64) scriptlet failed, waitpi d(9271) rc -1: No child processes Error in PREIN scriptlet in rpm package mysql-community-server-8.0.12-1.el7.x86_ 64 Verifying : mysql-community-common-8.0.12-1.el7.x86_64 1/5 Verifying : mysql-community-client-8.0.12-1.el7.x86_64 2/5 Verifying : mysql-community-libs-8.0.12-1.el7.x86_64 3/5 1:mariadb-server-5.5.60-1.el7_5.x86_64 was supposed to be removed but is not! Verifying : 1:mariadb-server-5.5.60-1.el7_5.x86_64 4/5 Verifying : mysql-community-server-8.0.12-1.el7.x86_64 5/5

Dependency Installed:
mysql-community-client.x86_64 0:8.0.12-1.el7
mysql-community-common.x86_64 0:8.0.12-1.el7
mysql-community-libs.x86_64 0:8.0.12-1.el7

mariadb-server.x86_64 1:5.5.60-1.el7_5
mysql-community-server.x86_64 0:8.0.12-1.el7

Sorry, we unfortunately don’t have any instructions for upgrading to MySQL 8… we’ve also discovered some incompatibilities that people ran into when trying to do so.

Using MySQL 8 probably isn’t going to work for the time being. Jamie is looking into that, though we unfortunately don’t have an ETA.


Thank you Eric @andreychek for MYSQL 8 usage for now. In fact many people have been running 5,5 5,6 and also 5,7 for long time and when we start a new box and import old databases, we should be able to continue install older 5.5 to 5.7 versions which are mostly stable. I agree with mysql 8 being unstable for now.
Few months ago I setup a new system and uninstalled mariadb and added 5.6 and it did not create any issues. But now when i try uninstall mariadb either the remove is not full or it gets botched. Wish we could resolve this to enable install 5.5 to 5,7 for now.
Appreciate a lot if you and Jamie can look into this.

It took a lot of effort to finally remove mariadb as on a brand new system where mariadb is not installed its easier but once installed its hellish to uninstall it.
I had to remove everything and still mariadb server wont erase. I had to do manually from webmin.
It was a breeze then to install mysql community server 5.7 and if anyone is interested its supposed to be the version before mysql 8.0 which indeed is not fully functional with many scripts. From same mysql repo one can easily do mysql 8 too. FOR Now I am not doing it as critical is to remove mariadb or any other mysql and then install mysql repo that has 5.8 and 8 available. I did it on a CENTOS 7.6

any ETA or options to upgrade 5.7 to 8 now??


I would be happy to see this too :slight_smile:

Let us know if you have any news about it plz