Upgrade from virtualmin 3.43gpl to professional


I was impressed with virtualmin and so purchased the upgrade to pro. However, looks like the gpl version is ahead of what is available for professional. So I can’t upgrade to professional quite yet. I saw on the NEWs forum that professional will be posted today. Just bringing this problem to light. I’ll be patient as the new version gets released, but can’t wait to upgrade to professional. Message from the attempted upgrade process is below…


Creating Virtualmin license file …
… done

Downloading and installing modules …

Installing virtual-server version 3.42 …
… version 3.43.gpl is already installed
Some errors occurred while upgrading your system to Virtualmin Pro. Please check the messages above for possible causes.

Hey Rod,

Great to have you on board as a Virtualmin Professional Early Adopter. Sorry for the inconvenience on the upgrade! I’m rolling out 3.43 as we speak. Should be available in less than half an hour. Hopefully that’ll resolve the upgrade issue for you–the Upgrade feature in GPL is still pretty new and not very well-tested. But, as with all things, we’ll help if anything blows up. :wink:

Cool. I just did the upgrade. Looks like it worked. I’ll play around with it and see how things work. I don’t have much experience with virtualmin yet; but have experience with webmin.


trying to upgrade and I recieve the following message…

Downloading and installing modules …

  Installing virtual-server version 3.45 ..
  .. version 3.45 is already installed

  Some errors occurred while upgrading your system to Virtualmin Pro. Please check the messages above for possible causes.

But… I don’t have VM Pro only the gpl version.

Howdy javacup,

Yep, this just came up with the new fancy pants RPM-based upgrade process (the older upgrade process left users with .wbm modules, which is somewhat less than ideal from a management perspective, even though we also have a good wbm-based updates manager built into the package updates module, so it’s mostly an invisible difference).

Anyway, I’ve rolled out a new version of the virtual-server RPM that should fix this problem…but I’m guessing the older version is cached.

I’m running a test upgrade now, and will figure out how to workaround this particular quirk and post back here momentarily.

Hey Joe,

Any luck?

I believe 3.46 of GPL and Professional resolves all of the known problems with GPL->Pro upgrades–it is rolling out to the repositories in the next hour or two. Once both are available, you can upgrade to 3.46 of GPL, and then try the upgrade again. If it fails with 3.46, drop me an email and I’ll look into it personally (and finish the upgrade for you).


Thanks for the reply and rolling out 3.46.

I don’t have your email address so I’m posting here. When upgrading the RPM through the Webmin “Software Packages/Install Packages” mechanism, I get the following:

Install failed :

This Webmin module is already installed on your system.
error: %pre(wbm-virtual-server-3.46.gpl-1.noarch) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping wbm-virtual-server-3.46.gpl-1

You may attempt to install again by going back to the previous page and selecting different install options.

Otherwise, click here to delete the temporary package file in order to save disk space.


Crap. Still broken. I’ll build a new 3.46-2 package today completely free of this pre script test, as it obviously is not behaving correctly no matter how we write it.


As of today I still don’t have any indication that there is a 3.46-2.

I’m sure you’re working on it but a special request, pleaes let me know when you post it so I can make sure I grab it.



It’s magic. Instead of trying to upgrade the Virtualmin software, I decided to try to get virtualmin to upgrade itself to pro again… and it worked. Don’t know why but it did and so I’m set.

Thanks for your help.