Updated Virtualmin today via Webmin dashboard on 2 servers but one server won't load dashboard or apache websites

I ran the latest Virtualmin update in the dashboard today on 2 servers and while the update was running I lost connection to the web dashboard on both servers. I gave a couple of minutes and one of the server’s Webmin dashboard came back online and all apache websites are accessible on this server.

With the second server the Webmin dashboard is inaccessible and I can’t access any of the apache website running on this server. I’ve tried restarting both webmin and apache2 services and I’ve tried rebooting the server.

I can ping and SSH fine, I’ve checked Webmin logs and Apache2 logs and there are no errors logged and the services seem to restart without any issues but there’s just nothing on the web access. I have no recent backup of the virtual servers on this server and ideally could do with an easy fix :slight_smile:

I did nothing different across both server updates but only one of my servers is working afterwards.

Any help in diagnosing and fixing is appreciated.


In my case, whenever I have access via SSH but no access via HTTP (websites and webmin) I find that it’s a firewall issue. Usually flushing iptables in SSH fixes it

iptables --flush

just a thought.

Flushing iptables worked.

Thanks for your help.

Virtualmin adds rules to allow all of the ports it needs during installation, but if you’ve installed an alternative firewall or otherwise done something that changes the firewall since installation, you’d need to make sure those ports are opened in the new firewall.