Updated to 2.100 and applied new repo. Now receiving GPG Error with 'apt update'

OS type and version Ubuntu 23.04
Webmin version 2.100

Upon updating to webmin 2.100 I receive the notification on the dashboard that there was a new repo. I clicked through to apply the new repo and now receive a gpg error with ‘apt update’…

W: GPG error: https://download.webmin.com/download/newkey/repository stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2D223B918916F2A2
E: The repository 'https://download.webmin.com/download/newkey/repository stable Release' is not signed.

I confirmed that the new webmin.list file contains the new repo:

deb [signed-by=/usr/share/keyrings/debian-webmin-developers.gpg] https://download.webmin.com/download/newkey/repository stable contrib

and I verified that they debian-webmin-developers.gpg file exists in the location as indicated.

I do not know what else to check, any guidance is greatly appreciated.

have you cleared the package cache?

yes. Just ran apt clean again to be sure. Same result

Fixed by comment on GitHub issues for webmin…



cat /usr/share/webmin/webmin/developers-key.asc | gpg --dearmor >/usr/share/keyrings/debian-webmin-developers.gpg
1 Like

Solved my problem too. (I had to import the key as super user, didn’t work as a sudo user at Unbuntu 22.04 LTS )

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.