Update Webmin and Virtualmin not possible

OS type and version: Ubuntu Linux 20.04.3
Webmin version: 1.981

Hi I can’t update my server.
I have a Virtualmin licence but this is a Webmin issue.

When I try to update I get this error

Reading package lists…
Building dependency tree…
Reading state information…
E: Unable to locate package Alternative/

I don’t know where Alternative/ comes from?
Somebody a clue?

I’m thankful for any help.

Not a Webmin issue.

Your package repositories are misconfigured or it’s otherwise in some sort of broken state.

On the command line try the following:

sudo apt-get update

I assume you’ll get the same error. Check your apt sources and fix whatever is broken. Webmin/Virtualmin didn’t do it. :wink:

You could try fixing repos by downloading (from your Virtualmin Account page) and running install.sh script with -s flag to fix repos and exit, like:

sh install.sh -s

This is not a solution to the problem OP is having.

The topic says that update for Webmin and Virtualmin is not possible, and as it is most likely repo mis-configuration issue, my suggestion should just fix the repos, so it will be later possible to just run apt-get upgrade to install latest Webmin and Virtuamin packages.

“E: Unable to locate package Alternative/”

That’s something else. I don’t know what, I’ve never seen it. I have to assume the apt repo configuration has garbage in it.

@Swingkid1938 As you are a Pro user you can create a private ticket with us, attach as a zip /etc/apt directory and we will fix that for you.

Hi guys.

I think that Ilia is right. What ever package I want to upgrade I get the same error message. I changed also some URLs in the repository list but same error message.

What happens if you run apt-get clean && apt-get update && apt-get upgrade?

Let’s try it.

[root@srv ~]# apt-get clean && apt-get update && apt-get upgrade

It doesn’t allow me to post more then two links

Reading package lists…
Reading package lists…
Building dependency tree…
Reading state information…
Calculating upgrade…
The following packages will be upgraded:
command-not-found linux-firmware openssh-client openssh-server
openssh-sftp-server python3-commandnotfound ubuntu-advantage-tools usermin
9 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 155 MB of archives.
After this operation, 8782 kB of additional disk space will be used.
Do you want to continue? [Y/n] Abort.

And cursor blink

Yep. Greetings to Ilia he was right. It functioned. Server is up to date. Maybe now it’s possible to update the server Let’s Encrypt cert.

Thanks very much. Have a nice day and keep going.

HI me again.

I wanted to upgrade the server because I’m having an issue with Let’s Encrypt. It can’t update the certs any more. And we were wondering why the past upgrade error mentioned Alternative/.

If I look at the error message from Let’s Encrypt I also find Alternative/:

certbot [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] …

Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
it will attempt to use a webserver both for obtaining and installing the
certbot: error: unrecognized arguments: Alternative//110329_10539_3_letsencrypt.cgi --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’

Do you know what it could be. One Cert after the other is loosing validation and the first of my clients is asking why he is getting a cert error in outlook.

Thanks for your help in advance.

What the heck did you do to your system? That’s just bizarre. Like, I’m having a hard time imagining how this could happen.

You’re going to need to find where that’s coming from. I can’t guess.

I’d start with this to try to find it: sudo grep -R 'Alternative/' /etc/

That may or may not find a clue. Maybe it’s something in profile or bashrc. Maybe it’s something else. It’s weird as hell, whatever it is. I don’t know how you’d make it appear on every command line like that.

Thanks for your prompt feedback and help. I don’t hack around on servers I don’t know well, especially on servers with client accounts. I set up the server about a year ago and the only thing I did was doing the updates that webmin/virtualmin advised me to do and about a month ago I started to get the message that the Lets Encrypt certificates validation couldn’t be prolonged. The same error message I posted here.

I ran the command and got this response:

root@srv:~# sudo grep -R ‘Alternative/’ /etc/
grep: /etc/alternatives/jsonschema: No such file or directory
grep: /etc/alternatives/php-fpm.sock: No such device or address
/etc/webmin/config:tempdir=/home/TMP Alternative/
/etc/webmin/virtual-server/domains/16066611891954484:certbot: error: unrecognized arguments: Alternative//821435_41237_2_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/16066611891954484:certbot: error: unrecognized arguments: Alternative//275709_41237_4_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/1620222702584807:certbot: error: unrecognized arguments: Alternative//322214_41237_5_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/1620222702584807:certbot: error: unrecognized arguments: Alternative//869491_41237_6_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/16066654742026718:certbot: error: unrecognized arguments: Alternative//230653_41237_7_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/16066654742026718:certbot: error: unrecognized arguments: Alternative//620483_41237_8_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/160525843816378:certbot: error: unrecognized arguments: Alternative//201684_53794_2_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/162009350132022:certbot: error: unrecognized arguments: Alternative//97158_41237_9_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/162009350132022:certbot: error: unrecognized arguments: Alternative//774917_41237_10_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/161227164032693:certbot: error: unrecognized arguments: Alternative//536541_41237_11_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/16298292904049973:certbot: error: unrecognized arguments: Alternative//62197_41237_12_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/16298292904049973:certbot: error: unrecognized arguments: Alternative//631924_41237_13_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/1635808374128015:certbot: error: unrecognized arguments: Alternative//120351_41237_14_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
/etc/webmin/virtual-server/domains/1635808374128015:certbot: error: unrecognized arguments: Alternative//518453_41237_15_collectinfo.pl --os_type ‘debian-linux’ --os_version ‘11.0’ --real_os_type ‘Ubuntu Linux’ --real_os_version ‘20.04.3’
grep: /etc/systemd/system/oem-config.service.wants/gpu-manager.service: No such file or directory
grep: /etc/systemd/system/dbus-org.freedesktop.timesync1.service: No such file or directory
grep: /etc/systemd/system/display-manager.service.wants/gpu-manager.service: No such file or directory

What do you have set for temporary files directory on Webmin ⇾ Webmin Configuration: Advanced Options?

Sorry :blush:

I found it. We had the same idea. I set it back to default. I remember that we had some problems making scheduled Virtualmin backups because the partition got out of space. Then we changed it as a workaround till we found a solution for the problem. And as usually, if you don’t do it immediately right, you will never do it right. Is it really a problem changing it? Do I have to consider something when I change it?

Thanks for your Help.

Keep going your all doing a great job here.

What were you trying to accomplish with this? This can’t possibly work, and it’s made a mess of everything Webmin ever setup for you with a per user temp dir.

Of course you can change it, but what you changed it to doesn’t make sense.

Edit: To be clear, that’s two separate values, where only one can be used. The two values are /home/TMP and Alternative/. A space makes this two values in a UNIX shell.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.