Update fails due to PPA issue

OS type and version Ubuntu Linux 20.04.6
Webmin version 2.105
Virtualmin version 7.10.0
Related packages SUGGESTED

Hello… this morning I attempted to update my Ubuntu system and I received this error

Failed to fetch http://ppa.launchpad.net/ondrej/php/ubuntu/dists/focal/InRelease Could not connect to ppa.launchpad.net:80 (2620:2d:4000:1::81), connection timed out Could not connect to ppa.launchpad.net:80 (, connection timed out

I’m sure I’m not the only one who ever received this! But I thought I’d ask your advice on how to resolve it first since I don’t want to do anything that would cause a problem with my Virtualmin system!

Search the error, this could be another bug (or old one) in launchpad that needs the source list manually updated on your end

Virtualmin does not use PPAs, nor does it use PHP. Virtualmin won’t break because of a PHP problem, but your apps might.

But, if you rely on whatever PHP packages you get from that repository, you should look into why it’s failing.

Those URLs are working for me, so I’d guess it’s a network problem on your end (or possibly a temporary problem that has been resolved).

It seems to be down

That is clear enough!
so who cares? It is their problem - if their site is down or corrupt

It was more of an answer to reassure the user and tell him that it’s not a connection problem that only he has. Especially not to waste his time looking for a solution that doesn’t exist, since their server doesn’t seem to be working.

1 Like

It seemed to be a temporary problem with the server for these files. I had 76 packages to update so instead of updating all of them at once I just selected a few at a time and I eliminate the ones that were a PHP update. That way I could do one PHP version at a time.

Anyway… at the end of the day everything worked!

Tnanks for all the assistance from both you and Joe!

are you sure that you don’t have any software that is hosted on launchpad, There are loads of software repros hosted there. I Think there are a few Ubuntu repro’s hosted there look at https://launchpad.net/ … who runs ? it oh that would be Conical wonder what software they produce ?

Absolutely certain!

But it still remains their problem (and their users, though that is not me) that their site is down/intermittent

I thought you used Ubuntu … sorry for my mistake

Not a mistake I do use Ubuntu but nothing using PPAs. or “launchpad”

… and still do not understand why PHP was dragged into this.

Did you not look at the ppa that failed ?

1 Like

The PPA issue has been resolved. I loaded one at a time and it worked! I think the problem may have been on their end.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.