Update BIND config in domains


I changed my BIND config for the default server template (I changed primary dns hostname and added secondary dns). But I don’t know how to update all my existing domains to use this new config. Their DNS records are still the old ones. I tried to make new server template, and apply it to existing domain, but still no change in BIND config for this domain. Only new virtual servers actually use this config. How to change BIND configuration for my existing virtual servers?

There isn’t really a good way to apply changes to the BIND config in the Server Template to existing domains, as that risks losing any customizations that have been done to the DNS for those domains.

However, if you’re sure there are none, you can always disable the DNS feature for the domain, then re-enable it, which would then use the new config you created in the template.

You can do that for all your domains at once using the command line tools, using “virtualmin disable-feature” and “virtualmin enable-feature” to disable/enable the “dns” feature.

But again, remember that doing so will lose any customizations you’ve already performed to your DNS settings :slight_smile:


Thank you very much! It’s what I was looking for. I was aware that I will probably loose custom changes, but it is no problem :-).