Update 2.104 to 2.105 gives an error

OS type and version centos 7 and almalunux 8
Webmin version 2.104

When trying to update either via webmin itself via webmin - webmin configuration - update webmin
or via a cluster, both give this error

Failed to upgrade from www.webmin.com : No version number found at www.webmin.com


I am also getting the same error. I think its still not available from webmin.com. Using APT is working fine. I am using Ubuntu server 22.04 LTS. Maybe you should try upgrading using DNF or YUM command.

or maybe Webmin → System → Software Package Updates

yes i agree. that should also work.

Webmin isn’t installed via the repositry, but via a downloaded rpm, so dnf or yum won’t work for us.

Software packages updates is a front-end for yum/dnf, so if yum/dnf doesn’t know about a package, so won’t package updates.


use this command 2 commands to setup repo

curl -o setup-repos.sh https://raw.githubusercontent.com/webmin/webmin/master/setup-repos.sh

sh setup-repos.sh

Then you can update webmin via yum command or from software packages updates section.

Thank you for those commands, but they won’t work for us. We have webmin on a number of servers and manage them via the cluster function. Our prefered way is the webmin build in method as we don’t want to have yet another repositry on our servers.


Try this then

yum install wget

wget https://github.com/webmin/webmin/releases/download/2.105/webmin-2.105-1.noarch.rpm

rpm -U webmin-2.105-1.noarch.rpm

It should work for you.

Yes it does and i know it does, i have already downloaded it from sourceforge and installed the rpm via the cluster with “from uploaded file”.

But that was not my post. My post was about reporting a bug in the build in update method so someone with access and knowledge could fix it for every webmin user.


Ok i got you. It will be fixed soon by the developers. If everything is working fine then its ok.
@Ilia sir please fix it. I am also getting the same error.

@Jamie, we somehow lost meta tags for passing Webmin and Usermin versions. It’s fixed now! Please rebuild webmin.com.

@Linulex As Jamie rebuilds webmin.com it should work then.

1 Like

Ok, rebuilding now!

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.