Unrecognized SSL certicate - Virtualmin Version 7

OS type and version debian 11
Webmin version 2.101
Virtualmin version 7.8.23
Related packages SUGGESTED

Hello, I am encountering a problem with the SSL on destok-tout.fr certificate, in fact in the virtual server tab, I open server configuration, then manage the SSL certificate and I have:
Issuer name: ZeroSSL RSA Domain Secure Site CA
Organization of the issuer: ZeroSSL
Expiration date: Sep 21 23:59:59 2024 GMT
Certificate type: Signed by the CA

SSL certificate file /etc/ssl/virtualmin/169411997263672/ssl.cert
SSL private key file /etc/ssl/virtualmin/169411997263672/ssl.key
Certificate Hash Type RSA

However, and after restarting the services, I still have no recognized certificate ERR_SSL_PROTOCOL_ERROR

I don’t understand why Apache doesn’t apply it, I thank you in advance for your help

Is SSL enabled in the webserver configuration? Is port 443 open?

If you open these 2, are the matching the certificates you where sent?

Yes this good ssl.cert and ssl.key

where can I check this? (I’m sorry but I’m a novice)

I get http:// opening, like there is a redirect

where should we do the Redirection and how to do it in virtualmin or Webmin, a tutorial to offer me?

Well virtualmin by default runs on 443 and 80. Have you edited any apache config files?

Did you enable the server features in Virtualmin UI? “Apache SSL website enabled” must be checked.

You can take a look inside this directory /etc/apache2/sites-enabled and check your VM configuration file.

<VirtualHost …:80>
<VirtualHost …:443> => for SSL

Apache ports in Debian can be found in this file /etc/apache2/ports.conf.
Listen 80
Listen 443 => for SSL

I check and see the redirections.
I also checked the VM files are configured on port 80 and 443
we listen carefully to both in the config file

no I didn’t make any changes

If the webserver configuration is correct, then the problem must be looked for elsewhere.

  1. The certificate must be checked in the command line with openssl.

  2. Check the encryption protocols.

  3. The certificate may be expired.

  4. Check and update the system date and time.

There are many resources if you do a search on the Internet for this error displayed in your browser ERR_SSL_PROTOCOL_ERROR.

BTW - why are you using ZeroSSL certificates when you have already in Virtualmin Let’s Encrypt? You can try a self-signed certificate too.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.