Unable to yum update


I just installed a fresh install of webmin, usermin and virtualmin on my Centos 5.6 box. Everything seems to be working fine, except when I want to run phpmyadmin. “Requires PHP 5.2+”
I checked the version and it notes I have php 5.1.6 installed:

Installed Packages
php.x86_64 5.1.6-27.el5_5.3 installed

I wanted to preform an update, and got this result:

yum update
Loaded plugins: fastestmirror, protectbase
Loading mirror speeds from cached hostfile

  • base: mirror.denit.net
  • extras: mirror.denit.net
  • rpmforge: ftp-stud.fht-esslingen.de
  • updates: mirror.denit.net
    0 packages excluded due to repository protections
    Setting up Update Process
    Resolving Dependencies
    –> Running transaction check
    —> Package awstats.noarch 0:7.0-2.el5.rf set to be updated
    –> Processing Dependency: perl(Geo::IP) for package: awstats
    —> Package clamav.x86_64 0:0.97-1.el5.rf set to be updated
    —> Package clamav-db.x86_64 0:0.97-1.el5.rf set to be updated
    –> Processing Dependency: clamav-server = 0.96.5-1.vm.el5 for package: clamav-server-sysv
    —> Package clamd.x86_64 0:0.97-1.el5.rf set to be updated
    —> Package rpmforge-release.x86_64 0:0.5.2-2.el5.rf set to be updated
    —> Package scponly.x86_64 0:4.6-4.el5.rf set to be updated
    –> Running transaction check
    –> Processing Dependency: clamav-server = 0.96.5-1.vm.el5 for package: clamav-server-sysv
    —> Package perl-Geo-IP.x86_64 0:1.38-1.el5.rf set to be updated
    –> Processing Conflict: clamav-filesystem conflicts clamav > 0.96.5-1.vm.el5
    –> Finished Dependency Resolution
    clamav-server-sysv-0.96.5-1.vm.el5.x86_64 from installed has depsolving problems
    –> Missing Dependency: clamav-server = 0.96.5-1.vm.el5 is needed by package clamav-server-sysv-0.96.5-1.vm.el5.x86_64 (installed)
    clamav-filesystem-0.96.5-1.vm.el5.x86_64 from installed has depsolving problems
    –> clamav-filesystem conflicts with clamav
    Error: clamav-filesystem conflicts with clamav
    Error: Missing Dependency: clamav-server = 0.96.5-1.vm.el5 is needed by package clamav-server-sysv-0.96.5-1.vm.el5.x86_64 (installed)
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.

I admit, this will not solve the phpmyadmin problem, but I need to update my packages …

If anybody has a solution for the php5.2, please also let me know. Tanks :slight_smile:


It looks like you have some third party repository’s enabled there, such as rpmforge.

The problem is that the packages within it may conflict with those you’re using for Virtualmin.

In particular, what you’re seeing right now are conflicting results for how to deal with ClamAV… yum isn’t sure what to do, and is delivering the errors you’re seeing.

My recommendation is to disable the third party repositories you have enabled. If you have any specific packages you want from a given third party repo, that may be okay (depending on the package), but my recommendation there would be to only pull down the packages you need, rather than open up the entire repo.


Dear Eric,

Thank you very much for the comprehensive explanation of the problem.
I removed the rpmforge repos and updated yum. Yum anounced there were no packages to update.
This keeps me a bit troubled though with the issue that I can’t run php5.2?

Thanks again

Ah, right, I forgot to mention about PHP 5.2 :slight_smile:

By default, CentOS provides what you’re seeing there, PHP 5.1.6.

To use an updated PHP version, you have one of two options.

First, since CentOS 5.6, they began offering an optional package named “php53”, that you can use in place of your current PHP version. But you’d only want to use that if all of your web applications supported 5.3.x, which not all of them do.

Second, you have the option of using the Virtualmin Bleed repository, which offers PHP 5.2 Documentation for that is here:


Thanks. It’s not that necessary yet so I need custom packages, I can wait for now (I think).


Turns out I need php 5.2 after all if I want to run the site I got the dedicated server for …
I’ve installed the bleed repos and set the includepkgs=php*
I’ve made a yum update and it asks me to install 15 packages from the bleed repos.

This is tricky though. If something goes wrong, formatting the server costs me a lot of money.

If I press the Y button (to update everything) and it doesn’t work / it breaks PHP, anything … Will I be able to downgrade again? If yes, what command can I use?

I’ve learnt never to remove the mcrypt package, and it’ll upgrade that. So I can’t just ‘remove’ the updated content and replace it …

All help is … again welcome :slight_smile:

Well, which 15 packages is it offering to install?

I can’t imagine any of the packages in the bleed repository would cause you to need to format your server though.

If you want to revert to the old packages – it’s not as straight forward as upgrading, but it can be done :slight_smile:

You’d first start by removing the bleed repository. Then, as I don’t believe yum has a reinstall option – you’d need to download the packages you want to revert to, and use rpm to install them from the command line. Using “rpm -i --oldpackage” I believe would do the trick.


Hey Eric,

The packages are as follows:

Dependencies Resolved

Package Arch Version Repository Size

php x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 1.3 M
php-cli x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 2.4 M
php-common x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 252 k
php-devel x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 549 k
php-gd x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 113 k
php-imap x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 50 k
php-mbstring x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 1.1 M
php-mcrypt x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 25 k
php-mysql x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 83 k
php-odbc x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 49 k
php-pdo x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 63 k
php-pear noarch 1:1.8.0-1.el5.vm virtualmin-bleed 396 k
php-pgsql x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 66 k
php-snmp x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 24 k
php-xmlrpc x86_64 5.2.17-1.el5.vmbleed virtualmin-bleed 51 k

Transaction Summary

Install 0 Package(s)
Upgrade 15 Package(s)

Thanks for the help. Now I feel confident I can upgrade :slight_smile:

Yeah, those are all just the PHP packages. Lots of folks have done that, I haven’t heard any complaints yet :slight_smile:

It certainly shouldn’t cause you to need to reinstall your OS, and you can always revert the packages later on if it’s not doing what you want.