Unable to update Usermin to 1.651


On 4 different servers I am getting this error when trying to update to 1.651:

Reading package lists... Building dependency tree... Reading state information... The following packages will be upgraded: usermin 1 upgraded, 0 newly installed, 0 to remove and 45 not upgraded. Need to get 9189 kB of archives. After this operation, 69.6 kB of additional disk space will be used. Err http://download.webmin.com/download/repository/ sarge/contrib usermin all 1.651 404 Not Found Err http://webmin.mirror.somersettechsolutions.co.uk/repository/ sarge/contrib usermin all 1.651 404 Not Found Failed to fetch http://webmin.mirror.somersettechsolutions.co.uk/repository/pool/contrib/u/usermin/usermin_1.651_all.deb 404 Not Found E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I didn’t try anything else so far … just wondering if I am the only one …


Hmm, what distro/version is it that you’re using there?

The URL’s in use there appear to be from Debian Sarge, which was released back in 2005, and isn’t around any longer.

It may just be a matter of updating your apt sources – what are the contents of your /etc/apt/sources.list?



It’s 2 servers with Debian 6 and 2 with Debian 7, all of them have alredy been updated numerous times … Webmin update to 1.740 went through flawlessly (on all 4, I just did the last one a few minutes ago, ok for webmin, same error for Usermin), Usermin has been updated quite recently if I recall correctly …

Apt sources have not been updated ever since theses VPS’s were installed, but I never had that kind of error, so I do not think this could be the problem.

There may be a problem with the apt sources now though – the repos it points to are so old they may no longer be valid in some cases.

Can you paste in the contents of /etc/apt/sources.list for one of your servers where you’re experiencing problems?



Here they are :slight_smile:

#deb http://ftp.fr.debian.org/debian squeeze main #deb http://security.debian.org/ squeeze/updates main contrib non-free #deb http://backports.debian.org/debian-backports squeeze-backports main

deb http://ftp.fr.debian.org/debian wheezy main
deb http://security.debian.org/ wheezy/updates main contrib non-free

deb http://download.webmin.com/download/repository sarge contrib
deb http://webmin.mirror.somersettechsolutions.co.uk/repository sarge contrib
deb http://software.virtualmin.com/gpl/debian/ virtualmin-wheezy main
deb http://software.virtualmin.com/gpl/debian/ virtualmin-universal main


Okay, I’d start by commenting out these two lines there:

deb http://download.webmin.com/download/repository sarge contrib deb http://webmin.mirror.somersettechsolutions.co.uk/repository sarge contrib

And after that, try running “apt-get update” – once you do that, does “apt-get install usermin” update it properly?



Well it kind of half-worked … “apt-get update” did work, then “apt-get upgrade” did upgrade Usermin from (according to what I saw on screen) 1.640 to 1.650 and now it says Usermin is up to date.
But il I log into Virtualmin/Webmin, dashboard says I have to upgrade to 1.651, but if I try (from both SSH or Virtualmin), it says that Usermin is already up to date …


Reviewing the Virtualmin and Webmin repositories, it doesn’t actually appear that there is a Usermin 1.651 yet.

Well, there is, but it’s only available in the development repository.

I wonder if one of those older repos that was enabled had metadata in it that was showing development software versions. If that were the case, it’s possible that got Virtualmin thinking there was a version available that wasn’t actually there.

Version 1.650 is the latest stable version of Usermin though, and is the one available in the main software repository.


Ok so there is an explanation, thanks for taking the time. I will comment out those lines on my other servers !