Unable to save feature: Postfix config missing system's host in mydestination?


I just tried to enable the subversion feature, but I get the error message

Failed to save enabled features : Your Postfix configuration is missing the system’s mail hostname domain.tld from the mydestination line, which will cause mail to bounce.

The hostname command returns ‘host.domain.tld’.

The /etc/hosts file lists my external IP and host.domain.tld.

The postfix config is valid and all mails are delivered perfectly.

The only “non standard configuration” at the moment is, that domain.tld is still handled by my old server, while host.domain.tld is handled by the new server. I also tried to use domain2.tld and host.domain2.tld (which is completely handled by my new server) in /etc/postfix/main.cf - but the result was the same.

Any idea what might be the issue here?

Thanks a lot in advance!



What distribution are you using?

And, just to clarify – is “host.domain.tld” listed on the “mydestination” line of your /etc/postfix/main.cf file?



the server runs with Ubuntu 10.04.

I tried both variants in mydestination: only the predefined $-variables and $variables plus explicitly providing ‘host.domain.tld’. None of the variants brought a change and they all still raised the error message when enabling the subversion feature. Thus I ended up in reverting mydestination to the $-only entries, ie

mydestination = $myhostname $mydomain localhost.$mydomain localhost


Try adding your full hostname to that line, as well as $mydestination .

So did you add the same hostname that is shown in Virtualmin’s error message?

Also, have you upgraded to Virtualmin 3.88 ? Some older versions displayed this error message incorrectly…

What if you just add the first part of the hostname to the mydestination line ?

If that doesn’t help, make sure there aren’t two mydestination lines in main.cf .

I’m completely confused now, as this doesn’t match at all what Virtualmin’s code does.

I think I’d have to login to your system myself to see what is going wrong here. Email me at jcameron@virtualmin.com if that is possible …

Ok, I see the issue now - your mydestination line had hostnames separated by spaces, but Virtualmin was expecting commas! Once I fixed that, the config check didn’t complain anymore about it.

Since a space-separated list of domains is actually legit, I will fix Virtualmin in the next release to handle this.