Unable to reinstall php

OS type and version Debian9
Webmin version 2.013
Virtualmin version 7.5

Good morning,
no longer able to update my server which was using Php 7.4 and Php 8.1, I made an error that disabled all versions of php. So I only have php 7.0 and most of my websites don’t work anymore.
I try to reinstall these versions of php but encounter many difficulties.
Following the directions at Multiple PHP Versions | Virtualmin, I am having the following issues:

apt update
Atteint:1 http://security.debian.org stretch/updates InRelease
Atteint:2 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-bionic InRelease
Ign:3 http://deb.debian.org/debian stretch InRelease                           
Atteint:4 http://deb.debian.org/debian stretch-updates InRelease               
Atteint:5 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal InRelease
Atteint:6 http://deb.debian.org/debian stretch Release         
Ign:7 https://mirrors.gandi.net/gandi/debian stretch InRelease 
Atteint:8 https://mirrors.gandi.net/gandi/debian stretch Release
Atteint:9 https://deb.nodesource.com/node_14.x stretch InRelease
Ign:10 https://packages.sury.org/php stretch InRelease
Err:11 https://packages.sury.org/php stretch Release
  403  Forbidden
Lecture des listes de paquets... Fait
E: The repository 'https://packages.sury.org/php stretch Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

The instructions on this page https://packages.sury.org/php/README.txt return errors to me

Err:13 https://packages.sury.org/php stretch/main amd64 Packages
   403 Forbidden
Ign:14 https://packages.sury.org/php stretch/main Translation-en
Ign:15 https://packages.sury.org/php stretch/main Translation-fr_FR
Ign:16 https://packages.sury.org/php stretch/main Translation-en
Reading package lists... Done
W: The repository 'https://packages.sury.org/php stretch Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Unable to retrieve https://packages.sury.org/php/dists/stretch/main/binary-amd64/Packages 403 Forbidden
E: Some index files failed to download, skipped, or used old ones instead.

I tried multiple times to modify the indications in sources.list and sources.list.d without success.
This problem seems to come from the gpg keys, but I cannot recreate the necessary ones.
Could you tell me a procedure to help me solve this problem?

Debian 9 reached end of life almost two years ago. I assume sury is no longer providing packages for it (which is entirely reasonable, it is dangerous to run a world-facing server on an unmaintained OS).

Hello and thank you for your response.
I am well aware of this and it is during the update for the migration that this event occurred.
I conclude from your answer that you see no other proposal than a complete reinstallation?

If you’re migrating to a new server, you don’t need your websites to work. All you need is Virtualmin working.

Just use Virtualmin to back up the sites, install Virtualmin on your new server, then restore the sites. It’s just that easy.

1 Like

I thank you for your answer and take good note of it, although it does not really answer the original question.
Can we say that this problem is solved and close the post?
Have a good day