Unable to install virtualmin on rhel 9

SYSTEM INFORMATION
OS type and version RHEL 9
Webmin version
Virtualmin version
Related packages

@Joe @Ilia

Error:-

[INFO] Started installation log in /root/virtualmin-install.log
▣:white_medium_square::white_medium_square: Phase 1 of 3: Setup
Installing core plugins for package manager [ERROR] Failed with error: 1
[ ✘ ]

[ERROR] Something went wrong. Exiting.
[ERROR] The last few log entries were:
[2023-01-05 17:30:31 IST] [DEBUG] Operating system version: 9.1
[2023-01-05 17:30:31 IST] [DEBUG] Operating system type: rhel
[2023-01-05 17:30:31 IST] [DEBUG] Operating system major: 9
[2023-01-05 17:30:31 IST] [DEBUG] Configuring package manager for RHEL 9.1 …
[2023-01-05 17:30:31 IST] [DEBUG] Disabling SELinux during installation …
[2023-01-05 17:30:31 IST] [DEBUG] setenforce 0 succeeded
Spin pid is: 8513
Updating Subscription Management repositories.
Red Hat CodeReady Linux Builder for RHEL 9 x86_ 7.1 B/s | 10 B 00:01
Errors during downloading metadata for repository ‘codeready-builder-for-rhel-9-x86_64-eus-debug-rpms’:

  • Status code: 404 for https://cdn.redhat.com/content/eus/rhel9/9/x86_64/codeready-builder/debug/repodata/repomd.xml (IP: 184.51.24.251)
    Error: Failed to download metadata for repo ‘codeready-builder-for-rhel-9-x86_64-eus-debug-rpms’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
    Installing core plugins for package manager: [2023-01-05 17:30:35 IST] [ERROR] Failed with error: 1
    [2023-01-05 17:30:35 IST] [ERROR] Something went wrong. Exiting.
    [2023-01-05 17:30:35 IST] [ERROR] The last few log entries were:

Hello,

Have you tried using the latest development version of install.sh script?