Unable to Install Virtualmin 7 - Getting Error

I can access the Virtualmin homepage (https://software.virtualmin.com/) without any issues, but when I try to install Virtualmin 7 on my Ubuntu server, I encounter an error. The installation process seems to fail with the error message “Something went wrong. Exiting.” and provides a log with the following relevant entries:




(Reading database … 74560 files and directories currently installed.) Removing ufw (0.36.1-4ubuntu0.1) … Skip stopping firewall: ufw (not enabled) Processing triggers for man-db (2.10.2-1) … (Reading database … 74463 files and directories currently installed.) Purging configuration files for ufw (0.36.1-4ubuntu0.1) … Processing triggers for rsyslog (8.2112.0-2ubuntu2.2) …

I’ve tried running ‘sudo apt update’ and ensuring all repositories are enabled, but the issue persists. Could someone please guide me on how to resolve this installation error and successfully set up Virtualmin 7 on my Ubuntu server?

Thank you in advance for any assistance!

Is this a clean OS? What Ubuntu version are you installing on?

Thank you for your response. I am using an Ubuntu version 22.04.3, but I have also tested on lower versions of Ubuntu, the latest Debian, and the latest AlmaLinux, and I am still getting the same error. All of my operating systems were freshly installed, and Virtualmin was the first thing I was trying to install on them.

Not sure what your doing, but I tested on both and works fine.
Ubuntu 22,04.04

and AlmaLinux 9

I believe I’m facing connectivity issues possibly due to the internet restrictions in my country . Are there any other mirrors available for testing purposes?
2- Additionally, could someone suggest a solution to diagnose the root cause of the problem and resolve it?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.