Some notes to myself, just in case it happens again
Made some progress with the errors. One site gave an example of what the proftpd.conf file should look like in regards to the TLS error that I’ m getting. I noticed that the tag was missing, so I added it, and its closing around the lines for the TLS information (this was at the end) so it now looks like this
<IfModule mod_tls.c>
Include /etc/proftpd/conf.d
TLSRSACertificateFile /etc/proftpd/proftpd.cert
TLSRSACertificateKeyFile /etc/proftpd/proftpd.key
TLSCACertificateFile /etc/proftpd/proftpd.ca
TLSEngine on
</IfModule>
Now i receive the following error
Timeout detected. (data connection)
Could not retrieve directory listing.
Error listing directory '/home/<siteName>/public_html'.
So I’m off to double check what that’s all about.
Edit: Again, if anyone has some hints or advice, let me know. Any assistance is appreciated.
Second, the directory timeout means the passive FTP connection is blocked. Make sure TCP ports 49152-65535 are allowed by your hosting provider’s firewall or forwarded through NAT.
Thank you kind internet denizen, for you are a god amongst mortals!
Not to future self and anyone else facing this issue…
virtualmin install-service-cert --domain example.com --service proftpd --add-global
did the trick.
I needed to start from scratch because i fiddled with everything too much, and the proftpd.daemon woudn’t start. but after i reinstalled virtualmin, the same issues happened the above supplied code fixed it easy peasy!