unable to connect to virtualmin

Everything was working fine (multiple web sites, virtualmin, usermin access) until I ran the configuration check and got the message “Virtualmin is configured to setup DNS zones, but the system is not setup to use itself as a DNS server. Either add to the …”

I went to the DNS server and sure enough, was not there so I added as a nameserver (I think - in the webmin.log file is nameserver2). The next configuration check gave the same error, so I restarted the server to make sure it got the config file. Now the web site(s) work, but I cannot access the virtualmin or usermin locations either using the host name:port or IP:port. II get “unable to connect” message in my browser. I can still remote access using filezilla on port 22 and see everything that permissions allow.

I went to the miniserv.error log and the last entry (on August 11) was an error where an IP was not using the SSL mode. Two entries before did not have a date were “failed to initialize a SSL connection”.

I also had a warning that I was using an IP provided by by router DHCP, but I did nothing to change to static IP. One problem at a time.

So my question is - what config file can I change to undo what I did so I can access virtualmin admin again?


You may just need to start them up… try running these commands from the command line:

/etc/init.d/webmin start /etc/init.d/usermin start

Also, regarding static vs DHCP IP addresses, there’s details on fixing that up here:


Thanks for the fast reply. That did it. In the past, they always started up when it booted. I went to the boot and shutdown page and they were listed as “no” for start on boot. I clicked the box and clicked start on boot, but it still indicates “no” on the status page. I rebooted and indeed I had to manually restart. What’s up?

Are you by chance using Ubuntu? If so, you may be seeing this issue with Ubuntu’s upstart:


The fix is to run this command:

update-rc.d webmin defaults

Wow andreychek - you are fantastic. That was it. Now I remember updating webmin about the same time as these troubles began. The command you gave fixed webmin to boot, but not usermin. No problem. I can always start usermin from webmin if that starts up.

Thanks again.


Well, you can use that same command to fix Usermin – just substitute the name “usermin” in place of "webmin:

update-rc.d usermin defaults