Unable to connect SSH Server from my local terminal

Ubuntu 22.04
Webmin 2.105

After a long time I decided to install ubuntu with Nginx server that forced me to install OS multiple times.
With ubuntu 20.04 I had the same problem that I have now with ubuntu 22.04 install.

Copied and pasted the password and username(ubuntu) offered by OVH link and logged in normally, so immediately I typed sudo passwd to change my password installed Virtualmin with LEMP without errors and logged in Webmin/Virtualmin panel with my own password and root (not ubuntu).

My problem starts here I can’t log in from ma MacBook terminal Permission Denied, The same with FileZilla using SFTP information Critical Error.

I have no Idea why this happens. With AlmaLinux or Centos never seen this issue. I didn’t change SSH port yet. Maybe a conflict between usernames root and ubuntu?

Thanks for any help or reply

Sounds like a permission or incorrect path issue. Which user do you use in FileZilla to establish the connection (root or superuser)? If root, there shouldn’t be a problem at all, if superuser, the default folder that FileZilla opens initially might not be accessible (because /root)…

The same user and password works fine on Webmin login page, it’s strange. Not only FileZilla but also from my computer terminal. As I said above commands of updates like php, Nginx etc I did using Webmin Terminal and I tried to change both username passwords again but no luck.

What user are you using in FileZilla? Root or superuser?

sftp://IP root password port(22 not changed) same method that I used for a long time with Centos or Almalinux

What does “server type” below the “Advanced” tab in your FileZilla server manager say? It should be set to default with no other option ticked there. Can you confirm, please?

I don’t see an Advanced Tab, with the same FileZilla I was using same method on Almalinux 8 I didn’t update the software on my pc.

Yes in Site Manager there is and Advanced Tab with the default server type selected

Strange, I had this problem once and only resolved by deleting FileZilla’s configuration but it had nothing to do with file permissions or path issues at all.

1 Like

I tried with Unix and same Authentication Failed, Critical error: Could not connect to server

I checked all options in Webmin - Servers - SSH Server but everything looks fine it’s so strange

Mac likes to put keys in ~/.ssh/known_hosts for you. Make sure you don’t have a conflict there.

of course I know that thank you, authentication is failed so it asks for the password but does not give permission

Alright explored again and I found the solution.
SSH ISSUE: Webmin - Servers - SSH Server - Authentication - Allow login by root? YES
Looks like Ubuntu does not allow them by default.
sercvice ssh restart and its okay now thanks to all replies and time you spent.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.