Unable to access Webmin following Update

I stupidly performed an update on Webmin via the panel on a production VPS. Immediately after the update (no errors) I lost access to the web min interface with the browser reporting that access is being denied.

I tried rebooting the VPS but it’s still not accessible. Cannot ping, cannot ssh. I’m currently logged via rescue mode. I even tried booting up with the VNC port provided by the VPS host (not sure exactly what its called) but even that does not work.

Any support would be most appreciated. Not really sure where to go from here, prior to the update the server was running very well with absolutely no problems.

Thank you in advance.


It’s always a good idea to perform a package updates.

What your describing though sounds very odd though. A Webmin update doesn’t impact things like SSH and Apache.

It sounds like you’re seeing a deeper problem at the moment.

What output do you see when booting your VPS? Are you able to see the bootup messages?


Thanks for the response Eric,

Turned out to be corrupted iptable. I have no idea how the corruption happened (but I have a theory). Anyway, I guess the web min update restarted networking or apache or something related and my iptable was already corrupt when it did that - network had just not been restarted yet.

Anyway, all up and running again and once again very happy with virtualmin.


Great, I’m glad to hear things are working properly for you now!