Unable to access port 10000 in web browser

would a firewall effect a local network? Can you ping the ip.

In the past, when I’ve been able to access with SSH but not through my browser I found that this command did the trick:

iptables --flush

this was with CentOS - I don’t know enough to say if the same applies to Ubuntu.


Hi, can you just check something within your pfsense, pc and server all connected to pfsense box? I think your issue could be that the server sits on a different subnet then rest of your local machines or its (not likely) fail2ban issue.

in your pfsense check which subnet server sits on, then have look at your local pc, which subnet it is sitting on. You can do this even from terminal on server and your local pc but pfsense have rather nice gui.

Basically if you running pfsence with different subnets you would have to link them properly. Normally on any router setup all devices are on same subnet so devices on LAN can communicate directly meaning you do not need to open any ports or any firewall rules. Most modern routers supports more subnets then one to isolate from each other and pfsense does have this function as well. It all depends on how you set up your pfsense towards your liking initially.

I know for the fact that I was able to set up on pfsense subnet 1 on wifi, subnet 2 on switch port eth 1 and eth2 and subnet 3 on eth 3 and eth4 on the same one physical device. I was not able to access devices connected to eth1 from wifi or from eth4 without a complicated additional setup.

Basically if your server sits on different subnet from your pc from which you are trying to access it via lanIP:10000 you wont be able to. - its just worth checking this out in your pfsense so you can eliminate this error possibility.

He’s already been given the solution. He is yet to even try it.

Pal, you can check your server all you want to and it’s going to tell you nothing because your problem isn’t your server. It’s pfsense because you haven’t configured it properly and continue to completely ignore the fact that it is the problem.

It all ( if pfsense is cause) depends on the config in combination with the switch and yes or no vlan and id’s and settings.

If it is inbound traffic to port, if not inbound then NAT rules for outbound.

But check client server connection first for all things and ports, easy to do pull the pfsense network cable.

Does this pfsense thing not have a traffic log that will tell you if it’s denying this traffic?

yeah sorry did not go via it all as classic issues like firewall or nat did not helped OP already

well that is what my post was all about problem is with pfsense configuration and you are wrong, you can check basic things like network details even from server in this case and compare with output on another pc and also I think you missed in my reply that I said he can actually check this from within pfsense.

@Gomez_Adams his issue is LanIP:10000 access means local network where you do not need even considering NAT unless his switch is managed type, and its not configured at all as it should be.

NAT is for WanIP:10000 = PublicIP:10000 which he is not after. For local access or Lan access you do not need NAT to even touch it, not even on pfsense.

All I was doing is trying to help and since its not firewall and not fail2ban and it is not NAT as you do not use NAT on the local network - it could be subnets be it messed up on pfsense or on switch if the switch is managed and or unless his switch is not configured at all (if its managed type), then NAT solution on switch itself would make sense to check. No one even mentioned it here and this is basic networking.

Anyway as he is connecting everything within his local network from the switch, I strongly suspect its issue with subnets. I bet, when he connects the server and pc directly to pfsense box, his problem will be gone.

Why are you so itchy, what’s wrong man? Next time just flag my post for moderation as spam or something and I will gladly shut up.

Once again you go off on a tangent insulting people. I have not said a word to you for days since you flew off the handle the last time. You have done that nearly every single day for the last two weeks to pretty much everybody on this forum. I don’t know what you’re problem is, but you need to find a cure for it.

And no, he has never, ever checked his pfsense configuration. Or at least if he has, he has never said so and never posted any shots of how it’s configured.

Like Joe stated, he seems adamant that it is a Webmin problem and it isn’t. There is nothing wrong with his server at all, hence my comment that him checking it over and over again isn’t going to help him.

1 Like

If he ever actually looked at the configuration, he could figure that out very quickly. To my knowledge, he never ever has. That’s why I’ve posted the link to the pfsense configuration booklet to check it all out with. It has, to this point, been completely ignored.

It is not a problem with the configuration of the pfsense as the problem occurs on a standard router.

I am leaning toward a misconfigured iptable or firewall on the Ubuntu system. Currently investigating that.

No a firewall would not effect a local network and that is what lead me astray.

The issue seems to be with a configuration within Ubuntu (either iptable, firewall or something else).

UH sorry i thought i did twice minimum. :wink:

It all ( if pfsense is cause) depends on the config in combination with the switch and yes or no vlan and id’s and settings.

pfsense and smart switches with vlans configured could have some extra’s also local i think.
But he did write before also regular router no succes , so i think problem is or on client , or on webmin box some firewall, not allowing those ports , is the most simple explanation for me. I could be wrong though. :wink:

thanks @jotst. Ive missed that somehow :slight_smile:

1 Like

I have this problem to myself , with myself, don’t know how come, but definitly more stress to cope in those days, corona ( and or war) related.

So please let we all be kind against eachother to not going the bad ugly way, makes no sense at all in Forum where we try to help as best as we can. ALL OF US :smiling_face:

Sure nu CSF as example on that box? ( if csf then firewalld or other need a uninstall if installed)
While if installed that plugin then often you have to open 10000 and 2000 manually for that firewall.
( is the first i look if problem with ports)

Also clients could have firewall, windows itself have those ports maybe closed local traffic, of local other software firewaal.

Or even misconfigured (smart) local switch vlans and so.

I would say that it’s not a VLAN mismatch if he can get to 80.

I also said it’s basic packet delivery. The only way pfsense could be in path is if it’s actually the switch appliance as well, but that’s been ruled out.

Is there a vhost default of httpd .conf where a default HSTS is configured? Wgile this is yes then on for more ports or proxy? , for the domain and subdomains maybe also. ( and host.domain.yours if hsts rule is on for domain.yours including subdomains, then it should block if https is not configured right

Local acces is often then a problem combi https non https and hsts set somewhere.

Don’t know if it is related.

HSTS could be set and remembered by browser, before installation if this box / domain there also

Somewhere in virtualmin there is a “default” hostname / domainname set, i don’t know how this is related to ip, but if their is a config file for that assuming hsts is on who knows

While then trying https .

I also think newer installs default Virtualmin / Webmin are on port 10000 expecting https / ssl is this correct?

SSL proxy on or something expected and not working local?

UH NOT NICE you should have posted here, also in this forum that and how it is solved 5 days ago @mattvanderhoff ?

Okay. Finally solved this for the friend.

She had SimpleWall installed and it was blocking everything! I did not know it until I found we couldn’t ping websites then investigated further and wallah!

Thank you all!



Sorry about delay but yes I did find what caused the problem. Even though friend said no firewall other than pfsense was running there was in fact a firewall program. Albeit not in the system tray nor did Windows Firewall (which was off) say there was another firewall handling it.

Definitely threw me and many for a wild goose chase.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.