Unable to access port 10000 in web browser

SYSTEM INFORMATION
OS type and version ubuntu 20.04.4
Webmin version 1.990

installed webmin on ubuntu 20.04.4 but when i go to ip-address:10000 it says “your internet access is blocked”

but in the miniserv.conf file i allow the pc ip address
i have port 10000 to allow

what am i missing?

thank you in advance

Webmin does not block any IP by default. You do not need to add anything to the miniserv config file.

This sounds like a firewall issue, perhaps.

I don’t know what “your internet access is blocked” could even come from. That’s not a standard browser error and it’s definitely not and error Webmin would serve.

It’s going to depend on your setup.

If you’re doing it on your own computer through your own internet connection then you’ll have to set up port forwarding at your internet router to allow traffic through to port 10000.

If you have an online provider you need to check to insure that port 10000 is allowed as well.

That was with Chrome in Firefox it says page cannot be found but at 10.50.0.67 the server ip it shows apache 2

just trying to access webmin locally

This sequence of words in this order has no meaning. I have no idea what you’re trying to say.

Please include actual error messages you see, and not messages you’ve made up based on what you think is happening.



Is Webmin running?

Justchecked and yes

Just out of curiosity, can you run:

sudo lsof -i -P -n | grep LISTEN

Look in the list and see if port 10000 is being listened to. It should look something like this:

You mean a local install?
If so.
Kind of VM or real metalbox?
Firewall for ports in your network or device .?

only guessing

A real metal box server.

I built a webserver and it is running flawlessly but helping a friend build their webserver and now hit with an issue where we cannot get into http://ip-address:10000

running in local network or at hoster ?
Also some hosters, using firewall options in control panel for the network part.

If local network, by ips it looks like local? then also look for firewall or network things. ( in network or clients also)

port 10000 and also 20000 should be alowed then, if csf “firewall” for example is installed on the box itself check those ports to are alowed.

BOTH IPV4 AND IPV6 should be set in some firewall separate!

only pointing out things i know could be problem, but don’t know yours. :wink:

Dutch?

and checks Gomez_Adams post above

Locally in the house.

We did have a pfsense router but then tested it on a regular router. Same issue.

We are going to remove webmin and try again hopefully tomorrow.

Yes i did noticed local ip’s
So you have to check for ipv4 and ipv6 ports 10000 and 20000 are alowed in your network and your clients. for all or those ips’you are using.

Edit: also regular routers could have other ports blocked by default!

Also do the port listen as Gomez asked!
And check if a firewall is running on the virtualmin/webmin box, if for example csf is running often persons forget to enable for ipv4 and ipv6 those 2 ports on the box

Your router should have software that will have a port forwarding section. If you have not set up port forwarding on the router software itself, that is your problem.

Here’s an article on a PFSense router on how to set up the port forwarding rule. Your software may be different so just look up your router on how to do it.

@Gomez_Adams those rules are to acces from outside to his local.

I did understand all was local at his place.

So his device or something on network local, or even a firewall at the webmin box is blocking i guess.

I could be so wrong. :wink:

Read the thread. Why do you think he can see the default apache page going straight to the internal ip but not when he tries to go to the port itself.

I can see all ports for apps and other aplications within own local network here without those rules in router.
Only firewalls block if defaults or set here.
But as writen i could be so wrong. :wink:

But if he has a kind of “divided” network segments so pfsense or router is real between his local server and the same local but client you are right. I cant read well then. :wink:

Look, if he doesn’t have port 10,000 open on that router, which is a firewall, he will NEVER make it to Virtualmin.

It’s that simple.

I run the same exact setup.